Search found 1449 matches

by Gordon
15 Jul 2019, 04:48
Forum: B2 & B3 Support
Topic: Debian 10 "Buster"
Replies: 32
Views: 11250

Re: Debian 10 "Buster"

I just upgraded and it worked flawlessly. One thing I'm still tracking is why Shorewall doesn't see the iptables NAT modules any more, but I don't believe this to be a kernel problem. May like to check kernel config anyway. There have been some changes to Netfilter config names and whether or not t...
by Gordon
10 Jul 2019, 05:13
Forum: B2 & B3 Support
Topic: Debian 10 "Buster"
Replies: 32
Views: 11250

Re: Debian 10 "Buster"

For other curious b3-fans, the kirkwood-b3 device tree: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/arch/arm/boot/dts/kirkwood-b3.dts Yes. In case you should want to compile your own kernel, do note the 'gpio-led' section. The default state for these leds is in fact 'off...
by Gordon
09 Jul 2019, 06:08
Forum: B2 & B3 Support
Topic: Debian 10 "Buster"
Replies: 32
Views: 11250

Re: Debian 10 "Buster"

Those names you refer to are the so-called 'Predictable Network Interface Naming' names. That has actually been around for quite some time now, at least 5 years, and if it had applied to the B3 you would have already encountered that issue. As it stands, eth0 and eth1 are defined as such in the devi...
by Gordon
06 Jul 2019, 07:54
Forum: B2 & B3 Support
Topic: Booting b3 without battery or working CMOS clock
Replies: 1
Views: 2639

Re: Booting b3 without battery or working CMOS clock

Must be something else. I have a box that I use for maintaining the Bubbagen OS and that hasn't had a good battery for years already. That box never fails to boot.

One other thing to note is that the led should be coloured purple during boot. Red indicates an error.
by Gordon
06 Jul 2019, 07:42
Forum: B2 & B3 Support
Topic: How to boot a b3 in rescue mode with Debian
Replies: 2
Views: 2839

Re: How to boot a b3 in rescue mode with Debian

You probably used an unsupported USB stick. It's a bit tricky to say which ones are supported though, but it's all about the internal chip. As a rule of thumb it needs to be USB2 and its capacity should not exceed 8GB. Most chance of success appears to be with the cheapest possible USB sticks, often...
by Gordon
03 Jul 2019, 06:46
Forum: Announcements
Topic: mybubba.org still in use? Can I let it expire?
Replies: 3
Views: 7254

Re: mybubba.org still in use? Can I let it expire?

Hi Johannes, Wasn't aware that mybubba.org was yours. Thought Ubi registered it for hosting the Excito services temporarily as these were being transferred to Rodeus. Seems like the domain is still completely controlled by his servers, but it doesn't resolve e.g. my easyfind name and there's no (old...
by Gordon
27 Jun 2019, 11:52
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

Some stuff like having a separate boot partition might not be needed. Probably worth noting that the various newer environments published in the development forum all do in fact already have a separate boot partition. At least in the case of Arch, Gentoo and Bubbagen this boots an interstitial kern...
by Gordon
26 Jun 2019, 17:42
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

Sorry, no, not reset. What I meant is that the u-boot image itself contains default values for several/most/all of the variables you see being listed in the environment. Since the u-boot image is specifically created for this device it is very likely that the defaults are in fact the same as the val...
by Gordon
26 Jun 2019, 16:27
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

1) No, the flash should not touch the u-boot environment since this contains values unique to your device. I do believe that the flash image does contain defaults for at least some of the environment variables though and thus you'll likely get a better result from deleting a key then guess at its or...
by Gordon
26 Jun 2019, 13:09
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

sataroot and satadev are okay. sataboot seems incomplete to me, but that may be because you are running a custom u-boot version. Whether or not the defaults that are apparently implied (like the "uImage" file name) work out the same is impossible to judge by me. In any case, sataboot in my environme...
by Gordon
26 Jun 2019, 12:21
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

ehm... So what are the present values for "sataboot", "sataroot" and "satadev"?

Note: if dumping the full environment do anonymize the eth*, serial and key values - these values give access to your easyfind account.
by Gordon
26 Jun 2019, 02:22
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

Right. The 300GB is probably a SSD? It is a known issue that u-boot does not recognize certain types of SSD firmware which makes it impossible to boot from such a drive. I actually have such a drive in one of my B3s and to be able to use it I had to edit the u-boot environment to read the kernel fro...
by Gordon
25 Jun 2019, 07:14
Forum: B2 & B3 Support
Topic: Arch Linux - br0 is down, or has no allocated address
Replies: 2
Views: 3013

Re: Arch Linux - br0 is down, or has no allocated address

Seems likely.

In your case, since the bridge is in fact rather pointless because it only has one interface, I'd simply delete the bridge and link the protocol(s) directly to eth1.
by Gordon
25 Jun 2019, 05:58
Forum: B2 & B3 Support
Topic: b3 keeps resetting ** File not found uImage **
Replies: 15
Views: 6407

Re: b3 keeps resetting ** File not found uImage **

Your u-boot seems okay. According to the message it just fails to find the file "uImage" on the first partition of your HDD (/dev/sda1). Is this the original drive or did you swap it for something new?
by Gordon
17 Jun 2019, 14:48
Forum: Development
Topic: Bubbagen live-USB for B3 updated (version 1.12)
Replies: 1
Views: 3208

Note: installer issue

Note: I have been informed that this image has an issue with the installer if the harddrive in your B3 is smaller than 2.1TB. This has been corrected in the Bubba overlay. In case you are affected by the issue you should sync your portage tree and then re-emerge sys-apps/bubba-install eix-sync emerg...