[SOLVED] Install problem after B3 2.4 update

"The best web gui for controlling your home using Telldus Tellstick"
Post Reply
Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

[SOLVED] Install problem after B3 2.4 update

Post by Joric17 » 10 Feb 2012, 15:42

Hi,

This is what i get when I install Home Automation after making the admin user in the installation program.

Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
SELECT d.id, d.telldus_id, d.description, dt.type, dt.text AS typetext, d.date_added FROM devices d INNER JOIN devicetypes dt ON d.type = dt.id WHERE d.telldus_id =

I already installed Home Automation before without any problem. In the mean time I did a full system reinstall and a 2.4 update on my B3.

Any Help?

Thanks,
Eric
Last edited by Joric17 on 22 Feb 2012, 03:24, edited 1 time in total.

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Re: Install problem after B3 2.4 update

Post by Eek » 11 Feb 2012, 04:02

Is this the only error? or are there more?
cheers
Eek

Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Re: Install problem after B3 2.4 update

Post by Joric17 » 11 Feb 2012, 07:19

Hi Eek,

This is the only error. I can't continue te installation. Tried several times (delete HA directory complete, mysql database), always the same error.

Btw, tdtool works fine

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Re: Install problem after B3 2.4 update

Post by Eek » 12 Feb 2012, 15:13

strange, could be a mysql version problem.
cheers
Eek

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Install problem after B3 2.4 update

Post by DanielM » 21 Feb 2012, 01:28

Hi.
Sorry for the late reply... I don't think this has anything with upgrading B3 to do, rather with upgrading telldus-core. Apparantly telldus changed the output of tdtool slightly in 2.1, breaking our parsing of the output. Replacing your system/functions.php with the file below will fix the problem.

http://www.telldus.com/forum/download/f ... 45dfccabb4

/Daniel

Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Re: Install problem after B3 2.4 update

Post by Joric17 » 21 Feb 2012, 15:54

Hi Daniel,

Thanks for the reply but it seems the link to the fix is empty :(

Eric

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Install problem after B3 2.4 update

Post by DanielM » 22 Feb 2012, 01:13

Joric17 wrote:Thanks for the reply but it seems the link to the fix is empty :(
Strange. Try this one instead: http://www.telldus.com/forum/download/f ... 53bf7b7e55

/Daniel

Joric17
Posts: 13
Joined: 05 Nov 2010, 16:16

Re: Install problem after B3 2.4 update

Post by Joric17 » 22 Feb 2012, 03:23

Great, thanks Daniel

Regards,
Eric

Post Reply