Missing config files

"The best web gui for controlling your home using Telldus Tellstick"
Post Reply
fereous
Posts: 16
Joined: 28 Feb 2012, 05:12
Location: Lund, Sweden

Missing config files

Post by fereous » 31 Jul 2014, 04:22

The WD Green that came with my B3 recently went tits-up, so have to reinstall HomeAutomation among other stuff on a new WD Red.

However, I can’t for my life find any of the config files in the archive. Below is what gets dumped into the ha folder (= the contents of homeautomation_v3_0_1.zip freshly d/l’ed from karpero.mine.nu).

Any ideas?

Code: Select all

root@b3:/home/web/ha# l 
total 264
-rwxr-xr-x  1 root users   218 Jan 13  2014 .htaccess
-rwxr-xr-x  1 root users  1006 Jan 13  2014 ajaxinterface.php
drwxr-sr-x 13 root users  4096 Feb 25 23:42 api
-rwxr-xr-x  1 root users  2006 Feb 12 21:47 api.php
-rwxr-xr-x  1 root users  2204 Feb  6 21:22 api_readme.txt
-rwxr-xr-x  1 root users 58543 Feb 13 14:06 dbfunctions.php
-rwxr-xr-x  1 root users 56078 Feb 25 23:29 functions.php
-rwxr-xr-x  1 root users  6401 Feb 24 23:27 header.php
-rwxr-xr-x  1 root users  1284 Feb 24 22:46 header_mobile.php
-rwxr-xr-x  1 root users  2703 Feb 19 22:27 includes.php
-rwxr-xr-x  1 root users  5110 Feb 25 08:17 index.php
-rwxr-xr-x  1 root users  6312 Feb 10 18:13 infobox.php
drwxr-sr-x  4 root users  4096 Feb 25 23:42 install
-rwxr-xr-x  1 root users 18326 Jan 13  2014 license.txt
drwxr-sr-x  2 root users  4096 Feb 25 23:42 logs
-rwxr-xr-x  1 root users  4452 Feb 25 00:21 mobile.php
drwxr-sr-x 12 root users  4096 Feb 25 23:42 modules
drwxr-sr-x  6 root users  4096 Feb 25 23:42 parser
drwxr-sr-x  6 root users  4096 Feb 25 23:43 plugins
drwxr-sr-x  2 root users  4096 Feb 25 23:50 rawcommands
-rwxr-xr-x  1 root users 12187 Feb 25 23:57 readme.txt
drwxr-sr-x  7 root users  4096 Feb 25 23:43 resources
-rwxr-xr-x  1 root users  7138 Feb 16 11:52 run.php
drwxr-sr-x  2 root users  4096 Feb 25 23:43 scripts
drwxr-sr-x  4 root users  4096 Feb 25 23:43 sensors
drwxr-sr-x  4 root users  4096 Feb 25 23:51 system
--
Thomas

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Missing config files

Post by DanielM » 01 Aug 2014, 05:45

That's correct, the config files aren't included in the archive. They are created upon installation (which starts when you access the site for the first time). Or if you want to retain your old configuration you could simply copy in your old configuration files.

/Daniel

fereous
Posts: 16
Joined: 28 Feb 2012, 05:12
Location: Lund, Sweden

Re: Missing config files

Post by fereous » 01 Aug 2014, 13:25

Tack Daniel! I strongly suspected something like this. Now I can get on with the installation.
--
Thomas

fereous
Posts: 16
Joined: 28 Feb 2012, 05:12
Location: Lund, Sweden

Re: Missing config files

Post by fereous » 02 Aug 2014, 01:51

Just a quick follow-up: The reason why I looked for the config files was that they are mentioned in the wiki (»Rename the configuration file config_sample_linux.php to config.php« etc.) as well as in my own notes. I guess that this was valid for the previous version of HomeAutomation.

Anyhow, now my installation is up and running once again. A great big thank you to the creators of HomeAutomation!
--
Thomas

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Missing config files

Post by DanielM » 02 Aug 2014, 08:02

fereous wrote:Just a quick follow-up: The reason why I looked for the config files was that they are mentioned in the wiki (»Rename the configuration file config_sample_linux.php to config.php« etc.) as well as in my own notes. I guess that this was valid for the previous version of HomeAutomation.
Yep. That was true for versions prior to 3.0. I've removed some steps in the wiki now.

(btw, now the numbering in the wiki guide is screwed up. I hope nobody notices :D )

/Daniel

fereous
Posts: 16
Joined: 28 Feb 2012, 05:12
Location: Lund, Sweden

Re: Missing config files

Post by fereous » 02 Aug 2014, 09:20

Missing numbers, eh? As in:

The two rules for success in life are:
1) Never tell them everything you know.

8) (Sorry …)
--
Thomas

Post Reply