New release for Bubba|TWO: 1.1.4

Announcements of all software releases for Excito products
tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

New release for Bubba|TWO: 1.1.4

Post by tor » 25 Mar 2009, 18:31

New release for Bubba|TWO: 1.1.4

This is a new minor upgrade to the Bubba|TWO 1.1 release mainly containing bugfixes.

To upgrade a running system, make sure you don't have any activities running such as uploads, downloads, print jobs etc. Then log in as admin in web-ui. Choose "settings" menu entry. Choose "Update" in the sub menu. Press the "Update" button.

Since this upgrade contains a new kernel a reboot of Bubba|TWO after upgrade is adviced. Furter more, since new services has been added in this upgrade it is a good idea to review the running services and turn of any unneeded ones. To do so log in as admin in web-ui and choose services.

New features
  • Added AFP (Apple Filing Protocol) support. Storage data is now available also in native Mac AFP format.
Upgrades
  • Squeezecenter is upgraded to version 7.3.2
  • The manual was updated to match new features.
Significant bug fixes
  • Due to a shortcoming in the network driver, mdns (Which is used by fx the daap server, Mac and Linux address resolution) dropped out of sight after a some inactivity.
  • Under certain network loads Bubba would degrade in network performance. The new kernel should fix this.
  • Earlier upgrade broke usage of international characters in web admin. This should work once again.
  • NFS kernel support added in new kernel, earlier only "userspace" NFS was possible.

rewien
Posts: 127
Joined: 27 Sep 2008, 18:10

Post by rewien » 26 Mar 2009, 19:43

Hello Tor,

Does this update fix the load cycle problem on bubba two also?

Gr Rewien

dan13l
Posts: 50
Joined: 20 Apr 2007, 20:30

Post by dan13l » 27 Mar 2009, 10:38

I'm having a problem with AFP.

I've got all my iTunes music on Bubba|Two. I run iTunes on my mac, and point it at the correct directory on Bubba. It's been working fine.

If I connect to Bubba using AFP, and try to listen to music, Bubba stops responding after a few tracks and needs rebooting. The power button doesn't even work, I have to pull the plug. It did this three times in the space of one album's worth of music.

I've gone back to smb, and have listened to several albums back to back with no problems.

davidI
Posts: 49
Joined: 07 Oct 2008, 13:39

Post by davidI » 28 Mar 2009, 06:27

Great! nfs at last!

I just needed to do the following to get it working:

1) apt-get install nfs-common nfs-kernel-server

2) edit/create the file /etc/exports, /etc/hosts.allow and /etc/hosts.deny as appropriate.

3) exportfs -a

And then I could mount the bubba's FS on my Linux PC.

davidI
Posts: 49
Joined: 07 Oct 2008, 13:39

Post by davidI » 28 Mar 2009, 06:29

I experienced problems after the squeezecenter update. I solved them by doing a complete de-install of squeezecenter (including removing the database) and re-installing from scratch.

Now it works great!

Puma
Posts: 219
Joined: 29 Sep 2008, 06:30

Post by Puma » 28 Mar 2009, 06:38

[quote="davidI"]Great! nfs at last!

I just needed to do the following to get it working:

1) apt-get install nfs-common nfs-kernel-server

2) edit/create the file /etc/exports, /etc/hosts.allow and /etc/hosts.deny as appropriate.

3) exportfs -a

And then I could mount the bubba's FS on my Linux PC.[/quote]



When I do this.... can I see de complete bubba on windows XP as well??

puma

davidI
Posts: 49
Joined: 07 Oct 2008, 13:39

Post by davidI » 28 Mar 2009, 16:57

nfs is a protocol to unix/linux, and I guess Apple Mac now as well. Windows does not support nfs. For windows you need to use the smb (samba) protocol - now called cifs - which the bubbas supported since the beginning.

kastrom
Posts: 13
Joined: 29 Oct 2008, 17:56

Post by kastrom » 29 Mar 2009, 04:38

Squeeze center isn't installed after upgrade. After installing it still says it's not installed. How do I solve this?

/Kent

essence
Posts: 9
Joined: 10 Oct 2008, 16:06

Post by essence » 29 Mar 2009, 08:26

I have encountered the following reliability/stability issues after updating:
- samba server: Unable to connect to "/storage" with popcorn media player and Win XP clients. After shutting down AFP and other (for me) non-essential services samba is up again but with unstable operation, i e interrupted file transfers are experienced and power-cycle is needed.
- bubba two server hangs hard: Neither able to login via Web-gui nor via ssh.
The power button is not even possible to use for power-cycle, pulling the power cord is the only way to restore operation.

I have stored both the kernel log and samba log (noticed a core dump ...), pls let me know if I should mail them to the support.

Is there any simple way (i e GUI-supported) to roll-back?

BR,

dan13l
Posts: 50
Joined: 20 Apr 2007, 20:30

Post by dan13l » 29 Mar 2009, 09:12

Having similar issues to essence - I thought it was just the AFP addition that was causing me a problem, but last night Bubba locked during a smb transfer of a few files and needed a reboot.

These are all issues that weren't present prior to this latest firmare.

Daniel.T
Posts: 4
Joined: 25 Mar 2009, 05:56

Post by Daniel.T » 29 Mar 2009, 19:15

My Bubba have also locked several times after update to 1.1.4 during transfer over SMB.

But the speed of transfers is better after upgrade, 6.8MB/s over 100Mb/s network. (Discussed in other Topic).

MaverikCH
Posts: 58
Joined: 09 Mar 2009, 15:03
Location: Bern, Switzerland
Contact:

Post by MaverikCH » 30 Mar 2009, 20:28

hello, i had the squeezecenter problem too.

connect with ssh client like putty and login in with your regular user.
type in su and enter password excito
type in "apt-get -y update".

after going though some processes he tells you that you have to run a command manually (dpkg --configure -a). if you do, then you will get a interface willing to install squeezecenter. deny the question for updating db (mysql). afterwards it was done for me, i went to the admin page of bubba and there it was installed. only had to activate it and reboot bubba.
Last edited by MaverikCH on 30 Mar 2009, 22:36, edited 2 times in total.

MaverikCH
Posts: 58
Joined: 09 Mar 2009, 15:03
Location: Bern, Switzerland
Contact:

Post by MaverikCH » 30 Mar 2009, 20:38

sniff. i was pleased too early. even bubba telling me squeezecenter is installed and activated, i can't reach it over http://bubba:9000. i get timout.

i have no clue atm.

MaverikCH
Posts: 58
Joined: 09 Mar 2009, 15:03
Location: Bern, Switzerland
Contact:

Post by MaverikCH » 30 Mar 2009, 21:02

no i'm confused %-)

after a long long long while i tried it again. and now its running.
wtf..

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 31 Mar 2009, 04:50

Hi all,

Seems like there are some problems with the 1.1.4 upgrade even though we have tested it internally :( Our deepest apologies. (We are currently investigating matters)

A short summary on status atm:

Regarding Squeezecenter. It seems like it under some circumstances can fail the upgrade leaving it in a half installed state. This will result in the services menu saying that its not installed. In some occasions simply doing an upgrade again might fix the problem.

Regarding stability, this is a tougher issue. This is most likely due to the kernel upgrade.

essence, we would very much like your logfiles etc. Could you contact support@excito.com ?

/Tor
Co-founder OpenProducts and Ex Excito Developer

Post Reply