Release notes for BUBBA|2 1.3.0

Announcements of all software releases for Excito products
pa
Posts: 308
Joined: 06 Dec 2006, 04:38
Location: Sweden
Contact:

Re: Release notes for BUBBA|2 1.3.0

Post by pa » 13 Feb 2010, 07:34

Regarding the replacement of the firewall config, we try to do a "sanity" check to make sure that the unit is actually running a "decent" firewall, and that it should work with routing traffic. Obviously something triggered this to be "insane" ;)...

Is it possible for you to share the config so that maybe next time it will not be overwritten?

/PA

tuxlifan
Posts: 9
Joined: 13 Feb 2010, 07:06

Re: Release notes for BUBBA|2 1.3.0

Post by tuxlifan » 13 Feb 2010, 08:08

I have a similar "Badness at c0028508" entry in the syslog as mcg (and maybe wil) and created a new thread at http://forum.excito.net/viewtopic.php?f=9&t=2186

mcg
Posts: 36
Joined: 13 Nov 2009, 22:34

Re: Release notes for BUBBA|2 1.3.0

Post by mcg » 13 Feb 2010, 22:12

Here's the firewall I'm currently using. Honestly I understand that you have to tailor your update to users who don't hack things up like this. But what I would recommend in that case is to save a copy of the old firewall.conf, and point the user towards it, if you decide you need to replace it.

Code: Select all

# Generated by iptables-save v1.4.1.1 on Mon Dec 21 22:02:18 2009
*nat
:PREROUTING ACCEPT [7688:509828]
:POSTROUTING ACCEPT [93:12426]
:OUTPUT ACCEPT [4369:355396]
-A POSTROUTING -o eth0 -j MASQUERADE 
COMMIT
# Completed on Mon Dec 21 22:02:18 2009
# Generated by iptables-save v1.4.1.1 on Mon Dec 21 22:02:18 2009
*filter
:INPUT DROP [163:8800]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [44441:6812071]
-A INPUT -p tcp -m tcp --tcp-flags SYN,ACK SYN,ACK -m state --state NEW -j REJEC
T --reject-with tcp-reset 
-A INPUT -p tcp -m tcp ! --tcp-flags FIN,SYN,RST,ACK SYN -m state --state NEW -j
 DROP 
-A INPUT -i eth1 -j ACCEPT 
-A INPUT -i lo -j ACCEPT 
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT 
-A INPUT -p icmp -m icmp --icmp-type 11 -j ACCEPT 
-A INPUT -p icmp -m icmp --icmp-type 3/4 -j ACCEPT 
-A INPUT -p tcp -m tcp -m state --state NEW --dport 22 -m recent --set --name ss
h-clients --rsource
-A INPUT -p tcp -m tcp -m state --state NEW --dport 22 -m recent --update --seco
nds 60 --hitcount 5 --name ssh-clients --rsource -j SSHATTACK
-A SSHATTACK -m limit --limit 1/minute --limit-burst 5 -j LOG --log-prefix "SSH 
ATTACK: "
-A SSHATTACK -j REJECT --reject-with icmp-port-unreachable
-A FORWARD -i eth1 -j ACCEPT 
-A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT 
-A FORWARD -p icmp -m icmp --icmp-type 3/4 -j ACCEPT 
COMMIT
# Completed on Mon Dec 21 22:02:18 2009

mcg
Posts: 36
Joined: 13 Nov 2009, 22:34

Re: Release notes for BUBBA|2 1.3.0

Post by mcg » 13 Feb 2010, 22:13

Hmm, actually, it looks like I didn't save off my original firewall config after all. I had a couple of lines right at the beginning of the INPUT table to reject INVALID packets. No biggie.

essence
Posts: 9
Joined: 10 Oct 2008, 16:06

Re: Release notes for BUBBA|2 1.3.0

Post by essence » 14 Feb 2010, 11:25

My update from 1.2.1 to 1.3.0 is uncompleted with problems.
After update clients can not access via Samba (tríed 1 Win XP, one popcorn hour). :cry:

Please advise how to get server up and running and how to complete update.
(I am sending debug.log, kern.log and syslog to excito via email)

Some basic observations:
- The new wireless config web page is there and samba seams to be updated, se samba/log.all below.
- The Bubba home page version still shows 1.2.1 (after update + 2*reboot+ several retried update+reboot).
- When retrying the update process from web-gui, it terminates with a Horde related error, see syslog below.

I use a simple server only config, i e use my Bubba Two as a NAS, no email services is activated.

BR,
Kristian

syslog
- - -
Feb 14 16:30:01 bubba /USR/SBIN/CRON[4557]: (root) CMD (test -x /usr/bin/php && /usr/bin/php /usr/share/horde3/scripts/alarms.php)
Feb 14 16:34:50 bubba bubba-networkmanager: Starting up
Feb 14 16:35:01 bubba /USR/SBIN/CRON[4570]: (root) CMD (test -x /usr/bin/php && /usr/bin/php /usr/share/horde3/scripts/alarms.php)
Feb 14 16:35:03 bubba php5-cgi: {"bubba-frontend":"1.3.0","bubba-backend":"1.3.0","bubba-album":"1.3.0","filetransferdaemon":"0.50.19+b3","squeezecenter":"."}
Feb 14 16:35:11 bubba Bubba::Hotfix[4576]: 0, Server starting
Feb 14 16:35:13 bubba php5-cgi: {"stop":0,"statusMessage":"Checking for hotfixes","done":0}
Feb 14 16:35:18 bubba last message repeated 3 times
Feb 14 16:35:18 bubba Bubba::Hotfix[4578]: 2, Status: Failed to verify response from server, proceeding with upgrade
Feb 14 16:35:19 bubba php5-cgi: {"stop":0,"statusMessage":"Failed to verify response from server, proceeding with upgrade","done":1}
Feb 14 16:35:23 bubba Bubba::Apt[4603]: 0, Server starting
Feb 14 16:35:25 bubba php5-cgi: {"done":0,"logs":{},"statusMessage":"","progress":0}
Feb 14 16:35:28 bubba php5-cgi: {"done":0,"logs":{},"statusMessage":"Verifying pre upgrade system integrity.","progress":0}
Feb 14 16:35:30 bubba php5-cgi: {"done":0,"logs":{},"statusMessage":"Verifying pre upgrade system integrity.","progress":0}
Feb 14 16:35:31 bubba php5-cgi: {"error":1,"done":1,"logs":{"ERROR":[{"Data":"iF bubba-horde 3.3.5ex3 Horde installation for the bubba platform\n","Desc":"Failures found in package (dpkg) database, unable to continue with upgrade."}]},"statusMessage":"System integrity failure.","progress":100}
Feb 14 16:36:11 bubba Bubba::Hotfix[4578]: 0, Timeout: Bubba::Hotfix server terminating


samba/log.all
- - -
[2010/02/12 20:31:32, 0] lib/util_sock.c:read_data(534)
read_data: read failure for 4 bytes to client 192.168.0.191. Error = No route to host
[2010/02/12 20:31:32, 1] smbd/service.c:close_cnum(1150)
192.168.0.191 (192.168.0.191) closed connection to service storage
[2010/02/12 22:10:42, 1] passdb/pdb_tdb.c:503(tdbsam_open)
tdbsam_open: Converting version 3.0 database to version 4.0.
[2010/02/12 22:10:42, 1] passdb/pdb_tdb.c:282(tdbsam_convert_backup)
tdbsam_convert_backup: updated /var/lib/samba/passdb.tdb file.
[2010/02/13 21:50:12, 1] smbd/process.c:756(smbd_sig_hup_handler)
Reloading services after SIGHUP
[2010/02/13 22:06:36, 1] smbd/process.c:756(smbd_sig_hup_handler)
Reloading services after SIGHUP

Hammer
Posts: 124
Joined: 02 Oct 2007, 13:37

Re: Release notes for BUBBA|2 1.3.0

Post by Hammer » 14 Feb 2010, 13:25

Update went through ok it seems!

/Hammer

wm.bubba
Posts: 82
Joined: 11 May 2009, 12:58

Re: Release notes for BUBBA|2 1.3.0

Post by wm.bubba » 14 Feb 2010, 14:30

Along with others, I've also found that Samba stopped working after this latest upgrade.
I too can execute /etc/init.d/samba restart ,as root and it works until the next restart.

Is there a permanent fix in the offing for this, dos anyone know?

pa
Posts: 308
Joined: 06 Dec 2006, 04:38
Location: Sweden
Contact:

Re: Release notes for BUBBA|2 1.3.0

Post by pa » 15 Feb 2010, 02:08

Regarding samba, can you guys describe your setup as this is something that we do not see on our side.

Network profile?
Describe the network setup, any switches or anything? All information is interesting.

/PA

soovizzy
Posts: 19
Joined: 19 Sep 2008, 09:09

Re: Release notes for BUBBA|2 1.3.0

Post by soovizzy » 15 Feb 2010, 04:44

I got a failure when the upgrade was going on then

All releases are 1.3.0, but I havent restarted the Bubba2 servers since I need it to work and
i do not have time to fixa the horde if it would stop working
So it still says 1.2.4 as runnign release

If I run upgrade again I get the following message:
Failures found in package (dpkg) database, unable to continue with upgrade.
iF bubba-horde 3.3.5ex3 Horde installation for the bubba platform

How to proceed?

HeSitated
Posts: 30
Joined: 26 Jun 2009, 12:36
Location: Ede, The Netherlands

Re: Release notes for BUBBA|2 1.3.0

Post by HeSitated » 15 Feb 2010, 05:00

soovizzy wrote:All releases are 1.3.0, but I havent restarted the Bubba2 servers since I need it to work

[...]

How to proceed?
After upgrading from Etch to Lenny: You'll have to reboot!

wm.bubba
Posts: 82
Joined: 11 May 2009, 12:58

Re: Release notes for BUBBA|2 1.3.0

Post by wm.bubba » 15 Feb 2010, 12:38

Not sure what you mean Pa, but here goes.

The upgrade went through without any problems, BUBBA rebooted with no problems except Samba.

My BUBBA is set up as a Sever, and I'm accessing the partitions on the network from my Linux PC. Samba is set up correctly on BUBBA, to share my home drive and Storage.

Except since the latest upgrade to 1.3.0, the smbd service isn't stating at boot, as follows

Code: Select all

wies@bubba:~$ /etc/init.d/samba status
nmbd is running.
smbd is not running failed!
Personally, I'd just like to know how to get the smbd service to start at boot time.

Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Re: Release notes for BUBBA|2 1.3.0

Post by Binkem » 15 Feb 2010, 15:11

To anyone who did't notice:
Bubba|two is still running Debian Etch!

RobV
Posts: 34
Joined: 05 Oct 2008, 05:48

Re: Release notes for BUBBA|2 1.3.0

Post by RobV » 15 Feb 2010, 15:30

As stated earlier in this thread, my update failed.
In contrast with some of you guys my Samba is working fine after the reboot.

The only problems on my side seem that the wrong version number is shown in the web-ui and that the software upgrade mechanism doesn't work anymore.

When Excito would be interested, I could send any logging on request.

RobV

Lotussteve
Posts: 2
Joined: 16 Feb 2010, 02:09
Location: Austria

Re: Release notes for BUBBA|2 1.3.0

Post by Lotussteve » 16 Feb 2010, 02:17

Hello!

I can confirm the SAMBA-problem since this upgrade.

The first few times i got a RUNNING nmbd und a FAILed smbd, but now i´ve got them both running after boot but get a timeout when i try to connect (Nautilus, the GNOME file manager from an Ubuntu notebook).

After a /etc/init.d/samba restart everything works fine (and faster than before).

I have no log messages at hand (´m @work), but i think i remember seeing that it tries to bind to different ports, fails and then just idles around, while after the restart it gets the ports it wants, so it seems.

I have a bubba where i didn´t change the network settings (192.168.x.x) since the version i got it shipped with, so i didn´t choose any of the new "profiles" up until now. May this be the cause? Is something blocking SAMBA in setups like mine (i got the bubba working as a streaming server/NAS via 100mbit cable to a DSL-Router from where it is reachable in my LAN, WAN port not in use).

If you need any more informations please let me know, when i´m home i could go GREPping through the logs :) !

Thanks in advance for help with this nuisance,

Greetings from Austria,

Steve
Be the change you want to see in the world! (Mahatma Ghandi)

pa
Posts: 308
Joined: 06 Dec 2006, 04:38
Location: Sweden
Contact:

Re: Release notes for BUBBA|2 1.3.0

Post by pa » 16 Feb 2010, 02:59

The problem with the failed upgrades seems to be related to an earlier version of horde, the webmail client.

For those of you with shell access you can try the following from the command line as root:

Code: Select all

dpkg --purge --force-depends bubba-horde
apt-get -f install
These two commands will uninstall horde, thus removing all settings made in the webmail client such as identities, but not any user accounts or email, that is not related to the client itself.
The last command will then reinstall and upgrade the rest of the system.

Regarding samba, we are still working on this issue and we will try to get a fix for horde as well.

/PA

Post Reply