Release notes for Bubba 2 software version 2.0.5

Announcements of all software releases for Excito products
johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Release notes for Bubba 2 software version 2.0.5

Post by johannes » 26 Apr 2011, 08:41

Release notes for Bubba 2 software version 2.0.5
This is a new minor upgrade. The upgrade is available only as a software upgrade and not as an install image.

How to upgrade
To upgrade a running system, make sure you don't have any activities running such as uploads, downloads, print jobs etc. Then log in as admin in web-ui. Choose "Settings" menu entry. Choose "Software update" in the sub menu. Press the "Update system" button.

Since the update service depends on root access to the MySQL database, if you have changed the default password the update will fail. If it has been changed, run the update from the command line. Default options should be ok, but you need to provide your MySQL root password.

Install
To (re)install a system please read the manual, section "INSTALLING & REINSTALLING SOFTWARE".

New features and major changes
Squeezebox server updated to 7.5.4.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

eds_oyo
Posts: 15
Joined: 22 Apr 2010, 07:10

Re: Release notes for Bubba 2 software version 2.0.5

Post by eds_oyo » 26 Apr 2011, 09:31

Thanks for the update, I've already installed it and it is working fine :) Great!

nolla
Posts: 22
Joined: 11 Mar 2011, 13:16
Location: Turku, Finland

Re: Release notes for Bubba 2 software version 2.0.5

Post by nolla » 06 May 2011, 13:46

Yep! For me it failed with "ParseError" when I tried to upgrade the system via web-ui. Apt-get upgrade -command upgraded bubba and squeezecenter.

nolla
Posts: 22
Joined: 11 Mar 2011, 13:16
Location: Turku, Finland

Re: Release notes for Bubba 2 software version 2.0.5

Post by nolla » 07 May 2011, 07:51

nolla wrote:Yep! For me it failed with "ParseError" when I tried to upgrade the system via web-ui. Apt-get upgrade -command upgraded bubba and squeezecenter.
Actually.. I guess the parse error comes from somewhere else..

MagnusJonsson
Posts: 88
Joined: 26 Sep 2008, 04:18

Re: Release notes for Bubba 2 software version 2.0.5

Post by MagnusJonsson » 16 Jun 2011, 14:58

Hi,

I tried the following
How to upgrade
To upgrade a running system, make sure you don't have any activities running such as uploads, downloads, print jobs etc. Then log in as admin in web-ui. Choose "Settings" menu entry. Choose "Software update" in the sub menu. Press the "Update system" button.
But when I press the button the following error appears

Image

and then things just revert back to showing the "Update system" button again. :cry:

Does anyone have any good ideas? (I can ssh into the machine and print some stuff if you need me to)

johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: Release notes for Bubba 2 software version 2.0.5

Post by johannes » 16 Jun 2011, 16:08

This is a normal message wih a bit too agressive font, if you just wait this message should dissapear. Doesnt it?
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

MagnusJonsson
Posts: 88
Joined: 26 Sep 2008, 04:18

Re: Release notes for Bubba 2 software version 2.0.5

Post by MagnusJonsson » 16 Jun 2011, 16:13

I was shown a progress bar that never (well anyway after 25 minutes) hadn't changed value from 0%.
Then I pressed F5 and was shown the regular first "Update system" button again.

Should I have waited even longer ? :oops:

RandomUsername
Posts: 904
Joined: 09 Oct 2009, 18:49

Re: Release notes for Bubba 2 software version 2.0.5

Post by RandomUsername » 16 Jun 2011, 16:36

O/T but wow! That screen shot is a blast from the past :)

MagnusJonsson
Posts: 88
Joined: 26 Sep 2008, 04:18

Re: Release notes for Bubba 2 software version 2.0.5

Post by MagnusJonsson » 16 Jun 2011, 16:43

Okay, I do admit that it was quite awhile since I updated the last time. The reason is that the last time I did update (well over a century ago :) ) the update did not progress too smoothly. The nice guys at Excito told me that the reason for this was that I had one of the first B2 units shipped and that software had a few flaws... (They really helped me out that time in a very nice way)

Anyway I was back on track again and since then I've seen no reason to update until I today purchased a Squeezebox Radio and it wanted me to update the Squeeze server Sw.....

RandomUsername
Posts: 904
Joined: 09 Oct 2009, 18:49

Re: Release notes for Bubba 2 software version 2.0.5

Post by RandomUsername » 16 Jun 2011, 16:59

Anyway, have you tired

Code: Select all

aptitude upgrade 
or

Code: Select all

aptitude dist-upgrade 
from the command line?

RandomUsername
Posts: 904
Joined: 09 Oct 2009, 18:49

Re: Release notes for Bubba 2 software version 2.0.5

Post by RandomUsername » 16 Jun 2011, 17:00

Or "tried" even. Why can't I edit my post :(

johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: Release notes for Bubba 2 software version 2.0.5

Post by johannes » 17 Jun 2011, 02:48

Yes, that old black system had a few bugs in the updater. One of them was showing 0% ready when the update had finished. But since you are still on the black system, the update obviously failed.

I suggest you try (if you don't mind some command-line-work) what RandomUsername suggested, and if it doesn't help, you can always send it to us and we'll do the upadte manually and get you a working fresh system. A third option is to let us in to your unit for a manual upgrade (email us ssh access).
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

MagnusJonsson
Posts: 88
Joined: 26 Sep 2008, 04:18

Re: Release notes for Bubba 2 software version 2.0.5

Post by MagnusJonsson » 17 Jun 2011, 04:02

RandomUsername wrote:Anyway, have you tired....
No, I have not... :oops:

So I tried

Code: Select all

aptitude upgrade
and tons of things happened with only one error

Code: Select all

dbconfig-common: writing config to /etc/dbconfig-common/bubba-album.conf
dbconfig-common: flushing administrative password
Replacing config file /etc/album/debian-db.php with new version
apache2: Syntax error on line 192 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/ports.conf: No such file or directory
 failed
invoke-rc.d: initscript apache2, action "reload" failed.
dpkg: error processing bubba-album (--configure):
 subprocess post-installation script returned error exit status 1
Setting up libkrb53 (1.4.4-7etch8) ...
and one warning

Code: Select all

Not starting S.M.A.R.T. daemon smartd, disabled via /etc/default/smartmontools (warning).
so final messages were

Code: Select all

Errors were encountered while processing:
 bubba-album
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up bubba-album (2.0.0.4) ...
dbconfig-common: writing config to /etc/dbconfig-common/bubba-album.conf
dbconfig-common: flushing administrative password
Replacing config file /etc/album/debian-db.php with new version
Reloading web server config: apache2
So trying to see what I got

Code: Select all

magnus@bubba:~$ cat /proc/version
Linux version 2.6.32.13 (tor@tor-desktop) (gcc version 4.3.4 (crosstool-NG-1.5.1) ) #1 Tue May 25 12:01:56 CEST 2010

magnus@bubba:~$ uname -a
Linux bubba 2.6.32.13 #1 Tue May 25 12:01:56 CEST 2010 ppc GNU/Linux
All in alla I assume is a good response.... However I can not access the webgui (webserver down ?) anymore.
I even tried to reboot, but that did not help, the web server still seems unavailable.
johannes wrote:A third option is to let us in to your unit for a manual upgrade (email us ssh access).
I will do some more troubleshooting, but otherwise I might just use this option.

Thanks both for your help!

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Re: Release notes for Bubba 2 software version 2.0.5

Post by Eek » 17 Jun 2011, 04:17

Yes, your Apache webserver is down
apache2: Syntax error on line 192 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/ports.conf: No such file or directory failed
This is what I have in the /etc/apache2 directory

Code: Select all

/etc/apache2# ls -ltr
total 56
drwxr-xr-x 2 root root  4096 Jan  1  1970 sites-enabled
-rw-r--r-- 1 root root   887 Jul  3  2009 privkey.pem
-rw-r--r-- 1 root root   899 Jul  3  2009 cacert.pem
-rw-r--r-- 1 root root     0 Sep 11  2009 httpd.conf
-rw-r--r-- 1 root root   378 Oct 26  2009 envvars
-rw-r--r-- 1 root root 10104 Oct 26  2009 apache2.conf
drwxr-xr-x 2 root root  4096 Sep 14  2010 sites-available
drwxr-xr-x 2 root root 12288 Sep 14  2010 mods-available
drwxr-xr-x 2 root root  4096 Sep 14  2010 mods-enabled
drwxr-xr-x 2 root root  4096 Sep 14  2010 conf.d
-rw-r--r-- 1 root root   516 Jan 19 19:30 ports.conf
And the contents of ports.conf

Code: Select all

/etc/apache2# cat ports.conf  
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

#<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
#    Listen 443
#</IfModule>
cheers
Eek

efiggy
Posts: 26
Joined: 21 Aug 2007, 06:38

Re: Release notes for Bubba 2 software version 2.0.5

Post by efiggy » 14 Jul 2011, 00:03

I having these errors when I run the aptitude upgrade

Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

anybody can help.

cheers,
efiggy

Post Reply