New firmware update 0.31.4

Announcements of all software releases for Excito products
Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 19 Apr 2007, 04:11

You can check by logging into Bubba via SSH (or telnet) and then at the prompt typing -

cat /etc/apt/sources.list

However, if you weren't aware of this file then it's unlikely that it will have got itself changed from the original default.

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 11:47

Clive wrote:You can check by logging into Bubba via SSH (or telnet) and then at the prompt typing -

cat /etc/apt/sources.list

However, if you weren't aware of this file then it's unlikely that it will have got itself changed from the original default.
The file looks like this:

deb http://ftp.se.debian.org/debian/ sarge main
deb http://security.debian.org/ sarge/updates main
deb http://ftp.se.debian.org/debian/ sarge non-free

deb http://update.excito.net/ bubba main

I haven't been touching this in the past so no changes should have been made to this file.

For the record, Bubba is still not able to find any updates :(

I also double checked my router and port 80, 21 and 443 is open.

Any comments from the administrators regarding this would be grately appreciated!

/Johnny

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 19 Apr 2007, 12:50

Hi Johnny,

What's the result of the following command (you'll need to be root):

Code: Select all

apt-get update

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 19 Apr 2007, 13:39

Hmm, looking at that sources.list it looks as if the Debian sources are not excluded from the update. As Tor mentioned, only the excito source should be active when updating from the web interface.

Make sure that the first three lines in the sources.list begin with a # so they are ignored via the update. Only the excito based source should be active (see my earlier copy/paste of the sources.list for an example)

These must be done from your root user.

(Excito - Any advice or comments ?)

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 13:46

bubbalibre wrote:Hi Johnny,

What's the result of the following command (you'll need to be root):

Code: Select all

apt-get update
Bubbalibre,

This is what I get:

Hit http://security.debian.org sarge/updates/main Packages
Hit http://security.debian.org sarge/updates/main Release
Hit http://ftp.se.debian.org sarge/main Packages
Hit http://ftp.se.debian.org sarge/main Release
Hit http://update.excito.net bubba/main Packages
Hit http://update.excito.net bubba/main Release
Hit http://ftp.se.debian.org sarge/non-free Packages
Hit http://ftp.se.debian.org sarge/non-free Release
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

/Johnny

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 19 Apr 2007, 13:53

All right. Try what's proposed:

Code: Select all

dpkg --configure -a
And then retry to update the packages' list:

Code: Select all

apt-get update

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 14:32

Clive wrote:Hmm, looking at that sources.list it looks as if the Debian sources are not excluded from the update. As Tor mentioned, only the excito source should be active when updating from the web interface.

Make sure that the first three lines in the sources.list begin with a # so they are ignored via the update. Only the excito based source should be active (see my earlier copy/paste of the sources.list for an example)

These must be done from your root user.

(Excito - Any advice or comments ?)
I added # in the beginning of the first three lines, saved and tried to update Bubba after that.....no luck! :(

johannes
Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Post by johannes » 19 Apr 2007, 14:37

First, do what bubbalibre suggests, to clear the error. Probably something went wrong when you tried updating from the web interface, since some other updates (from the debian sources) required user intervention, and thus, failed.

So, do the:

Code: Select all

dpkg --configure -a
And then retry to update the packages' list:

Code: Select all

apt-get update
And let us know how it goes.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 14:41

bubbalibre wrote:All right. Try what's proposed:

Code: Select all

dpkg --configure -a
And then retry to update the packages' list:

Code: Select all

apt-get update
Tried the codes and this is what I got (whenever I got a question I choosed not to change anything - proftpd etc.):

bubba:/home/username# dpkg --configure -a
Setting up samba (3.0.14a-3sarge4) ...
Starting Samba daemons: nmbd smbd.

Setting up proftpd (1.2.10-15sarge4) ...
Starting ProFTPD ftp daemon: proftpd.

Setting up ftd (0.5.5-1) ...
Starting Filetransfer daemon: ftd
Setting up php4-mysql (4.3.10-19) ...

Setting up libapache2-mod-php4 (4.3.10-19) ...
Forcing reload of web server: Apache2.

Setting up php4 (4.3.10-19) ...

Setting up bubba (0.31.1-1) ...

Configuration file `/etc/apt/sources.list'
==> Modified (by you or by a script) since installation.
==> Package distributor has shipped an updated version.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : background this process to examine the situation
The default action is to keep your current version.
*** sources.list (Y/I/N/O/D/Z) [default=N] ? N
admin:x:1000:100:Administrator:/home/admin:/bin/bash
Admin user already exists
Admin already a samba user
chown: cannot access `var/samba/public/*': No such file or directory
dpkg: error processing bubba (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
bubba
bubba:/home/username# apt-get update
Hit http://update.excito.net bubba/main Packages
Hit http://update.excito.net bubba/main Release
Reading Package Lists... Done

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 19 Apr 2007, 14:49

Good! Now you can use the interface's update button. It should work.

As johannes said, some debian's updates needed your intervention, preventing the process to complete.

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 15:19

bubbalibre wrote:Good! Now you can use the interface's update button. It should work.

As johannes said, some debian's updates needed your intervention, preventing the process to complete.
Tres bien......that worked like a charm!

Perhaps I should leave the # in front of the first three lines in the sources.list or not!?

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 15:25

johannes wrote:And let us know how it goes.
Thanks Johannes!

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 19 Apr 2007, 15:42

Johnny wrote:Perhaps I should leave the # in front of the first three lines in the sources.list or not!?
It depends...
tor wrote:Warning, if you have modified your apt sources the web-admin ui should not be used for upgrades.
You can either comment these lines and uncomment it only on purpose, when you need to install or upgrade a particular package. Or you can keep it and perform manual updates, using apt-get.

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 15:49

bubbalibre wrote:You can either comment these lines and uncomment it only on purpose, when you need to install or upgrade a particular package. Or you can keep it and perform manual updates, using apt-get.
Ok!

Thanks again for helping a noob!

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 19 Apr 2007, 16:12

bubbalibre wrote:
Johnny wrote:Perhaps I should leave the # in front of the first three lines in the sources.list or not!?
It depends....
I would always leave the # in front of the debian sources unless you need to manually load additional software from the Debian repositories.

This way, you can follow the Excito upgrade instructions without worry. I have struggled with Linux for years, but with Bubba it is great to be able to leave the upgrades to Excito and just follow the instructions for a stress free life.

I have used SUSE Linux as my main OS for a couple of years and I am fed up with with the amount of hacking I need to do just to make it work on a day to day basis. Bubba is great because I just do not have to worry about this, it does exactly what I need without constant intervention.

Post Reply