New firmware update 0.52.1

Announcements of all software releases for Excito products
Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 24 Feb 2008, 05:21

just a follow up.
I discovered that the m3u files only make it as a playlist if they are in the same directory as the mp3's and don't have any path.
example: test.m3u
song1.mp3
song2.mp3
To create a playlist where the songs are in different directories, you have to use the WEBUI http://bubba:49152/
create a container with class object.container.playlistContainer
In this container/playlist you can that create a class object.item.audioItem.musicTrack with Mimetype audio/mpeg and use an absolute path in the location (ex: /var/samba/public/music/S/Slipknot.mp3)
I find the WEBUI terrible, so i will try to hack the sqlite database :)
cheers
Eek

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 24 Feb 2008, 15:01

Hi Eek.

It really should work with paths as well. We have that while testing. Could it be the possible issue with slashes (windows \ vs Unix / ) as i mentioned above? That would give the exact problem you are describing.

/Tor
Co-founder OpenProducts and Ex Excito Developer

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 25 Feb 2008, 01:23

Hi Tor,

I tried al kinds of slashes...
but nothing seems to work in my case.
It only works if there is no path.

cheers
Eek

Boy
Posts: 34
Joined: 04 Jan 2008, 10:43

Post by Boy » 25 Feb 2008, 03:13

mountaindude wrote:Were there any changes made to the torrent engine (FTD)?
After upgrading to latest version from Excito, FTD crashes/dies when adding more than one torrent. Or sometimes even at the first torrent.
I've tried with various torrents to see if some of them were malformed, but the problem seems to be fairly general.

Anyone else seen this?
Yes, I have the same problem. I just tried to add four torrents shortly after each other to the torrent directory. I haven´t tried via the web-ui.

Regards
Boy

eeeuser1
Posts: 37
Joined: 03 Dec 2007, 05:06

Post by eeeuser1 » 25 Feb 2008, 06:39

tor wrote:Regarding playlists,

Eek is right it should work. We have tested it with m3u lists, pls lists should work as well, and they will be expanded in the "Upnp-filesystem" in the folder Playlists in the root. (Ie Audio,PC Directory, Photos, Playlists, Video)

So simply place a correctly formatted m3u list anywhere in the storage/{music,pictures,video} with relative paths to the content. And on the next rescan it should be available in the Playlists folder. (If you don't want to wait for it, stop and start upnp in the Web UI under Services.)

Things that might be problems here. Is things like incorrect relative paths. Wrong pathdelimiter, it most likely has to be unix /-slashes instead of windows \-slashes between directories in the playlist (This is not however verified) Wrong charset, it might be problems if the playlist content is not writtwen in the same characterset as the file/path names in the filesystem.

/Tor [/list]
Can we have the contents of a simple (small!) playlist uploaded or displayed here and an explination of which directory it was stored in and why.
this may be a big help to some of us.

Jeff

GettinSadda
Posts: 56
Joined: 22 Jan 2008, 06:06

Post by GettinSadda » 26 Feb 2008, 13:02

I have problems with downloads after the upgrade too :(

It seems that the downloaded does not close the file when it has finished downloading, so the last buffer-full is not written.

If you then clear the file from the downloads list it flushes the buffer and you can use the file - but it is a pain.

Kalle
Posts: 15
Joined: 02 Aug 2007, 15:54

Post by Kalle » 02 Mar 2008, 11:44

I don't know when it started, if it was with the upgrade (I think so), but lately I have had problems downloading torrents too. I've tried a lot of different torrents from multiple trackers. I save the torrents in the torrent-directory, then the web-admin freezes. It works again if I delete the torrent.

JohanSalo
Posts: 23
Joined: 17 Apr 2007, 10:05

Post by JohanSalo » 06 Mar 2008, 03:55

I have problem updating

Code: Select all

bubba:/home/johan/scripts# pico /etc/apt/sources.list
#deb http://ftp.se.debian.org/debian/ sarge main
#deb http://security.debian.org/ sarge/updates main
#deb http://ftp.se.debian.org/debian/ sarge non-free

#deb http://opensource.mgeops.com/stable/debian binary/

deb http://update.excito.net/ bubba main

Code: Select all

bubba:/home/johan/scripts# apt-get update
Get:1 http://update.excito.net bubba/main Packages [6187B]
Hit http://update.excito.net bubba/main Release
Fetched 6187B in 1s (3954B/s)
Reading Package Lists... Done

Code: Select all

bubba:/home/johan/scripts# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  bubbamon: Depends: bubba (>= 0.51.2-1) but 0.50.1-1 is installed
E: Unmet dependencies. Try using -f.
can i run

Code: Select all

apt-get -f upgrade
what will this do to my bubba?

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 06 Mar 2008, 15:41

Hi,

JohanSalo, you seem to have a strange setup. What apt is saying is basically that you have bubbamon installed or am trying to install it. Bubbamon however needs bubba package of at least version 0.51.2 but you only have 0.50.1.

Have you earlier tried to install bubbamon and that failed?

The reason that you wont get the latest version of the bubba package is that you "only" said apt-get update. Apt will then refuse to update packages with added dependencies. Which happens with the bubba package from time to time.

Could you try to do a apt-get dist-upgrade instead? I think that it will solve your problems.

If you run apt-get -f upgrade it will most likely uninstall bubbamon to solve the conflict.

/Tor
Co-founder OpenProducts and Ex Excito Developer

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 06 Mar 2008, 15:54

Regarding the problems with the download manager/ftd.

It seems like some of you have problems with this since the update. Could you either mail us on support@excito or add a note in the support forum and we could see if we could figure out what is wrong.

/Tor
Co-founder OpenProducts and Ex Excito Developer

JohanSalo
Posts: 23
Joined: 17 Apr 2007, 10:05

Post by JohanSalo » 07 Mar 2008, 02:43

Hi

after uninstalled the bubbamon i run upgrade.. noting happend..
installed bubbaMon (unsuccessfully) and typed...

Code: Select all

bubba:/home/johan/scripts# apt-get -f upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following NEW packages will be installed:
  libsasl2-modules postfix-tls
The following packages will be upgraded:
  bubba
1 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 552kB of archives.
After unpacking 868kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://update.excito.net bubba/main postfix-tls 2.1.5-9 [151kB]
Get:2 http://update.excito.net bubba/main libsasl2-modules 2.1.19.dfsg1-0sarge2 [160kB]
Get:3 http://update.excito.net bubba/main bubba 0.52.1-1 [242kB]
Fetched 552kB in 1s (523kB/s)
Selecting previously deselected package postfix-tls.
(Reading database ... 21434 files and directories currently installed.)
Unpacking postfix-tls (from .../postfix-tls_2.1.5-9_arm.deb) ...
Adding `diversion of /usr/lib/postfix/lmtp to /usr/lib/postfix/lmtp.postfix by postfix-tls'
Adding `diversion of /usr/lib/postfix/smtp to /usr/lib/postfix/smtp.postfix by postfix-tls'
Adding `diversion of /usr/lib/postfix/smtpd to /usr/lib/postfix/smtpd.postfix by postfix-tls'
No diversion `diversion of /usr/sbin/postconf to /usr/sbin/postconf.postfix by postfix-tls', none removed
Selecting previously deselected package libsasl2-modules.
Unpacking libsasl2-modules (from .../libsasl2-modules_2.1.19.dfsg1-0sarge2_arm.deb) ...
Preparing to replace bubba 0.50.1-1 (using .../bubba_0.52.1-1_arm.deb) ...
Upgrade
Installing symlinks
Unpacking replacement bubba ...
Setting up postfix-tls (2.1.5-9) ...
Fixing sdbm entry in /etc/postfix/dynamicmaps.cf
Starting mail transport agent: Postfix.
 
Setting up libsasl2-modules (2.1.19.dfsg1-0sarge2) ...
Setting up bubba (0.52.1-1) ...
admin:x:1000:100:Administrator:/home/admin:/bin/bash
Admin user already exists
Admin already a samba user
Reloading web server config...done.
Reloading Postfix configuration...done.
Reloading proftpd configuration...proftpd.
 done.
 
Setting up bubbamon (0.7) ...
Starting Bubba monitoring daemon: bubbamon.

bubba:/home/johan/scripts#
Efter this i had the right version and BubbaMon work gr8.

Thx tor for the support ;)

GettinSadda
Posts: 56
Joined: 22 Jan 2008, 06:06

Post by GettinSadda » 20 Mar 2008, 05:34

Is there a way to roll back this 'upgrade' to the previous version?

At the moment the downloads are useless and render the product "Unfit for purpose"

GettinSadda
Posts: 56
Joined: 22 Jan 2008, 06:06

Post by GettinSadda » 20 Mar 2008, 12:09

Another thing... Is the ftp downloader supposed to be able to download files > 2Gb? The manual does not mention any limit, and indeed shows a 2.2Gb file in the sample screen (although this is a torrent).

I have had two downloads fail in a row, both needed a reboot to get the server running again and both failed at exactly 2Gb.

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 20 Mar 2008, 17:42

Hi GettinSadda,

Sorry to hear that you have problems with the downloader. There really should be no big difference in the last two updates.

Could you please open a support issue, email support@excito.com, with this and we will see what we can do.

Regarding FTP downloads. Yes they are indeed limited to 2GB. This should be fixed in the Etch upgrade though. (Its a limitation in the library we use, libcurl, which is a newer version in Etch)

/Tor
Co-founder OpenProducts and Ex Excito Developer

Post Reply