Page 2 of 5

Re: Debian stretch (9) image 1.0 released for B3

Posted: 17 Aug 2017, 16:01
by Gordon
Judging by its name I'd say you got the wrong package. You need the `armel` version. If there is no such package you need the noarch version and either build the armel specific modules yourself or get them some place else.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 18 Aug 2017, 14:11
by anat
:shock:

Would this approach work better?
https://github.com/gordonb3/logitechmed ... cpan-armel

Is it the same Gordon behind that Git, by the way? :o

Re: Debian stretch (9) image 1.0 released for B3

Posted: 19 Aug 2017, 04:24
by Gordon
It might, yes that is me.

Problem is I can't really remember what compiler and library versions I used for creating those libs and I was recently confronted with the fact that this can cause incompatibilities. I think the Perl 5.22 and 5.24 modules were created with gcc 4.9 but the main issue would be the glibc environment. The Perl 5.22 modules may have been compiled against version 2.21 which might be okay for Stretch. The Perl 5.20 modules are the oldest, so if these are the ones you require this would offer the highest chance of success.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 20 Aug 2017, 14:24
by anat
I can''t understand a thing :?

Why neither of these worked out? and the server still gives the same error?
1.

Code: Select all

cpan[1]>  install DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 Su
b::Name
2.

Code: Select all

# apt install libev-perl libxml-perl libhtml-parser-perl libjson-perl libdigest-perl libyaml-perl libsub-name-perl

Re: Debian stretch (9) image 1.0 released for B3

Posted: 21 Aug 2017, 06:37
by Gordon
You're likely looking at version conflicts and search path issues. Are you still basing your installation on that .deb file? Then go to /usr/share/squeezeboxserver/CPAN and get rid of the `arch` folder. This folder contains files that will not work with the B3 and I fear that you will not be able to complete what is provided by this folder with either standard Debian packages or CPAN. The prescribed way to install on a platform for which no prebuilt binaries exist is to fetch the source files from https://github.com/Logitech/slimserver-vendor and run buildme.sh from the CPAN folder.

So what happens if you try to run LMS with the CPAN files provided on my github page? Do note that these are meant to be combined with LMS-7.8.0-noCPAN (http://downloads.slimdevices.com/Logite ... er_v7.8.0/).

Re: Debian stretch (9) image 1.0 released for B3

Posted: 12 Oct 2017, 08:22
by ryz
anat wrote:
17 Aug 2017, 14:39
The installation was very easy and straight forward! Thank you for the good work MouettE

The prolem is, I can't figure out how to get Squeezebox Server running. I installed http://downloads.slimdevices.com/nightl ... 23_arm.deb, but it complains about Perl libraries:
The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
Now before digging deeper into this, I'm just trying confirm that is this supposed be this hard or am I missing something?
I did found an unofficial build in this page close to the end https://nxa.at/post/build_squeezeboxser ... tch_armel/ which I did install and it seems to work fine.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 07 Nov 2017, 16:36
by evaluation
Hi,

first of all I want to thank you for this great stretch image!

I currently try to understand the shutdown mechanism with the button and it would be great if someone could give me some hints.

I try to get more control over the button to start some self defined actions depending on the button click pattern.
It seems to me that the button behaviour is not controlled by software. First I assumed that bubba-buttond has control over the button but it seems rather to be a stop mechanism for the shutdown process already initiated by the button itself.

Now the problem:
The stretch image immediately shutdown the system as soon as the button has been pressed. The original B3 image need the button to be pressed several seconds to start the shutdown process.
In stretch there is no such delay and the bubba-buttond seems to be useless. Is there a possibility to change the default delay of the shutdown?

Thanks in advance
Eva

Re: Debian stretch (9) image 1.0 released for B3

Posted: 07 Nov 2017, 16:59
by MouettE
Hello,

The button is still handled by bubba-buttond in the stretch image (it's a GPIO key event). The 2 seconds timeout should still be active and triggers the shutdown through a /sbin/shutdown -h now command.

All sources along with systemd unit files are in the b3-utils repository.

I will do a quick test tonight to check all this but it should be the expected behaviour.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 11 Nov 2017, 16:45
by Gordon
Hi,

I had a similar issue creating the systemd version of bubbagen. As it stands the kernel device tree source for the B3 actually does define the button as a power button and this is picked up by systemd which then calls its own handler for this event. The problem with this is that this handler essentially performs a `shutdown -h`and this will cause the B3 to get into a state where it will no longer respond to anything. To start the B3 again you must first disconnect power. The proper shutdown method stores a `magic` number to the flash memory and then performs a `shutdown -r` which will reboot the B3 into a preboot environment where it waits for the button to be pressed as a startup command. And of course the systemd method has a second disadvantage in that it responds instantly to an accidental touch as well.

To solve this you must go into logind.conf and set the value for `HandlePowerKey` to `ignore`. Like so.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 25 Dec 2017, 16:30
by Satrap
Tried to post something. But seems it's not working. :?

I've installed Debian Stretch on my Excito B3. seems for me like minimal installation. Which went quite smooth and easy, but is there a way to install original excito frontend?

Re: Debian stretch (9) image 1.0 released for B3

Posted: 26 Dec 2017, 21:29
by MouettE
Hello satrap,

The only newer operating system version with the updated excito frontend is the bubbagen build from Gordon.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 27 Dec 2017, 10:14
by Satrap
Hi,

thanks for quick reply. Yeah, I've already discovered bubbagen build and am already testing it.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 17 Jan 2018, 20:42
by UdfnYkyOj7F
thank s to u for this. minimal version is very good. makes me on easy rsyncer box to backup my puters. many many thanks also very easy by the instructions.

Re: Debian stretch (9) image 1.0 released for B3

Posted: 21 Feb 2018, 03:23
by kennywest
Very interesting read. I am still running wheezy on my box. If I would want to upgrade to stretch (fresh install) do I need to upgrade u-boot, like described here -> https://e.lefant.net/2014/08/31/debian- ... excito-b3/
If so, where can I find the most recent u-boot images?

Re: Debian stretch (9) image 1.0 released for B3

Posted: 21 Feb 2018, 22:41
by MouettE
You don't need to upgrade u-boot to use the stretch image, the kernel is patched to support the old version.