[gentoo|bubbagen] note for bubba-overlay users

Discuss development on Bubba
Post Reply
Gordon
Posts: 1339
Joined: 10 Aug 2011, 03:18

[gentoo|bubbagen] note for bubba-overlay users

Post by Gordon » 22 Jan 2018, 15:47

I'm currently working on some long overdue updates to how the old Excito applications are represented in the Gentoo bubba overlay. While I try to keep the transition as smooth as possible, some users may experience hick-ups during world updates. Since I'm not dropping any functionality these should all be easily solvable.

As you may have noticed the bubba overlay over time has gathered copies of older versions of packages from the regular Gentoo tree. The reason for this is that the Excito applications are essentially dead; they are not maintained and it is also not the objective of my project to take that responsibility on me. That said, if I can fix an incompatibility by applying a patch I will.

Obviously keeping old versions poses a hazard because the Gentoo mirrors are likely to drop these at some time. It may also cause issues with other packages you might want to install and that do require the newer version that is in the current Portage tree.

The first old package to be retired is dev-libs/libsigc++-2.4.1. This change has already been pushed onto the overlay and cause(d) rebuilds of bubba-diskmanager, bubba-networkmanager and filetransferdaemon. There has been no actual code change to these Excito applications though. Because libsigc++-2.4.1 is still available upstream the current installs will pull libsigc++ in as a static library rather than a dynamic one. i.e. the library is now part of the resulting binary itself. This change also obsoletes dev-libs/libeutils and both packages are due to be removed by end of February.

I'm currently working on combining the *bubba-info* packages into a single package. The four packages really represent the Debian way of thinking, making every individual module a package of its own, but that's not the Gentoo way. We have USE flags that determine what modules should be installed. I'm planning to release this update this week. Bubbagen users should experience no issues, Sakaki Gentoo users may see some blocks depending on whether their world content explicitly lists any of these four packages.

If there are more changes to report I'll post them in this thread.

Gordon

Post Reply