Gentoo and Bubbagen users: ffmpeg upgrade issue

Discuss development on Bubba
Post Reply
Gordon
Posts: 1325
Joined: 10 Aug 2011, 03:18

Gentoo and Bubbagen users: ffmpeg upgrade issue

Post by Gordon » 16 Nov 2018, 09:21

This week Gentoo freed ffmpeg version 4.1 in the main tree. As this is a major version upgrade this requires a rebuild of various applications that depend on this library. Unfortunately this new version drops support for legacy macro names that are needed for compiling forked-daapd. Should you be using this package or have it installed (as part of the @bubba3 world set) it is advised that you hold back on ffmpeg version 3.x by adding the following to your package.mask settings:

Code: Select all

# ffmpeg 4.x drops support for older macro names without the `AV` prefix.
# This causes compile of forked-daapd 23.2 to fail
>=media-video/ffmpeg-4
I am currently unaware of issues with other packages that have a dependency on ffmpeg.

Post Reply