Connect your B3 to your wireless network

A collection of tips on howto tweak your Bubba.
kenned
Posts: 12
Joined: 27 Feb 2011, 13:55

Connect your B3 to your wireless network

Post by kenned » 24 Mar 2011, 18:23

My ISP gave me a router with built-in DSL modem, so I can't use the B3 as a router. Also I don't care to have the B3 close to the router for several reasons. So I needed to use the B3 as a wireless client, serving files and webpages to the local network over wifi, and here's the recipe I followed.
I wanted to put it on the wiki, but couldn't be bothered to request a login.


=== B3 Wifi client ===
Configure the B3 as a wifi client to make it connect to a wireless router or an access point.

==== Prerequisites ====
You need to have a user account with shell access for the B3.
You also need to be able to log into the root account, either by using "su -" with the root-password, or by using "sudo su -" (which then needs to be set up in advance).

==== Disable B3 Access Point ====
Log in to the admin website on http://b3.local using the admin logon.
Click in to the Settings, Profile page and switch to the "Server only" profile.
Then enter the Settings, Network, Wireless page and turn off the wireless access point function of the B3.

==== Log on to the root account ====
Using an ssh application, eg. putty, log on to the b3 via ssh and log on to the root account.

Code: Select all

[user@MacBook: ~]$ ssh  192.168.1.11
Linux b3 2.6.35.4 #5 Tue Sep 7 16:06:15 CEST 2010 armv5tel

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Mar 24 22:38:42 2011 from macbook.local
user@b3:~$ sudo su -
[sudo] password for user: 
root@b3:~# 
The following commands all need to be run under the root account.

==== Install tools ====

Install wireless-tools and wpasupplicant packages like this:

Code: Select all

aptitude update
aptitude install wireless-tools
aptitude install wpasupplicant
==== Configure wifi device ====
Make the file /etc/network/interfaces readable only by root.

Code: Select all

chmod 600 /etc/network/interfaces
Enter the following section into this file (changing MyWifiNetwork and MySecretWifiKey with suitable values).

Code: Select all

auto wlan0
iface wlan0 inet dhcp
    wpa-ssid MyWifiNetwork
    wpa-psk MySecretWifiKey
This makes the wlan0 interface start at boot, connect to the network called "MyWifiNetwork" using the WPA PSK password "MySecretWifiKey" and request an IP address from the DHCP server.

Punch a big hole in the firewall for the wlan0 interface and restart the firewall to save the configuration.

Code: Select all

iptables -A INPUT -i wlan0 -j ACCEPT
/etc/init.d/bubba-firewall restart
Now start the wlan0 device to check the settings.

Code: Select all

ifup wlan0
The console will show that the device has connected to your WLAN, has sent an DHCP request and shortly after received a reply with the IP address to use.

Now enjoy your wirelessly connected B3.

Cheeseboy
Posts: 789
Joined: 08 Apr 2007, 12:16

Re: Connect your B3 to your wireless network

Post by Cheeseboy » 25 Mar 2011, 12:14

Now enjoy your wirelessly connected B3.
Good for you!
If you are too lazy to add it to the wiki, at least post it on the how-to thread.

Cheers!
EDIT: spelling
Last edited by Cheeseboy on 25 Mar 2011, 18:28, edited 1 time in total.

DanielM
Posts: 637
Joined: 28 Mar 2008, 06:37
Location: Sweden

Re: Connect your B3 to your wireless network

Post by DanielM » 25 Mar 2011, 13:15

Thanks for a good guide! Just moved it to the Howtos forum. And as Cheeseboy mentions, you should consider putting it on the wiki as well.

/Daniel

edaj0
Posts: 5
Joined: 24 Mar 2011, 10:48

Re: Connect your B3 to your wireless network

Post by edaj0 » 24 Apr 2011, 07:32

nice guide, thanks.
can anyone see any problems why this shouldn't work on a bubba 2, or should it?
thanks,
Jakob

Gizmo
Posts: 13
Joined: 26 Mar 2011, 09:53

Re: Connect your B3 to your wireless network

Post by Gizmo » 30 Apr 2011, 09:48

Bubba|2 - I'm working to fix for mine, but I'm apparently not that bright:

Code: Select all

bubba:~# ifup wlan0
ioctl[SIOCSIWPMKSA]: Invalid argument
ioctl[SIOCSIWMODE]: Device or resource busy
Could not configure driver to use managed mode
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

mon.wlan0: unknown hardware address type 803
Easyfind: nothing todo.
Firwall rewite, nothing todo.
mon.wlan0: unknown hardware address type 803
Listening on LPF/wlan0/00:80:48:69:9b:7f
Sending on   LPF/wlan0/00:80:48:69:9b:7f
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Easyfind: nothing todo.
Firwall rewite, nothing todo.
bubba:~#
Seems it's hardware type 803:

Code: Select all

bubba:~# dhclient3 wlan0
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

mon.wlan0: unknown hardware address type 803
Easyfind: nothing todo.
Firwall rewite, nothing todo.
mon.wlan0: unknown hardware address type 803
Listening on LPF/wlan0/00:80:48:69:9b:7f
Sending on   LPF/wlan0/00:80:48:69:9b:7f
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Easyfind: nothing todo.
Firwall rewite, nothing todo.

Gizmo
Posts: 13
Joined: 26 Mar 2011, 09:53

Re: Connect your B3 to your wireless network

Post by Gizmo » 30 Apr 2011, 10:39

HAH! A little more haste, less speed and some patience!
I forgot to switch off the WAP! :oops:

Thanks to Kenned for an excellent guide. Jakob - yes, works fine on Bubba|2

gringo
Posts: 10
Joined: 19 Feb 2011, 03:39

Re: Connect your B3 to your wireless network

Post by gringo » 13 May 2011, 17:32

All steps works fine, but the result of ifup wlan0 is:

Code: Select all

bubba:/home/marc# ifup wlan0
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Easyfll rewite, nothing todo.
Listening on LPF/wlan0/00:80:48:69:b8:3a
Sending on   LPF/wlan0/00:80:48:69:b8:3a
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Easyfind: nothing todo.
Firwall rewite, nothing todo.
I checked SSID & the Key two times. its right...

What can I do?

Thanx for helping me

gringo
Posts: 10
Joined: 19 Feb 2011, 03:39

Re: Connect your B3 to your wireless network

Post by gringo » 19 May 2011, 04:04

I found my problem...

when i install wpasupplicant (aptitude install wpasupplicant), it can't find the package.

I think i need edit the sources.list, but i dont know which source i have to add.

regards,
gringo

_NE_
Posts: 11
Joined: 29 Oct 2011, 04:46

Re: Connect your B3 to your wireless network

Post by _NE_ » 29 Oct 2011, 05:11

To get it to work with my WPA2 (PSK TKIP, hidden SSID) setup i had to do like this (found by google so i really don't know the fact behind it, but it worked).

Code: Select all

auto wlan0
iface wlan0 inet dhcp
        wpa-ssid your-ssid
        wpa-psk your-password
        wpa-key-mgmt WPA-PSK
        wpa-pairwise TKIP CCMP
	wpa-group TKIP CCMP
	wpa-proto WPA RSN
	wpa-ap-scan 1
	wpa-scan-ssid 1
Edit: found the reference, but as i'm a new user i can't add it (off site URL's blocked)

tiddler
Posts: 32
Joined: 07 Apr 2009, 03:23

Re: Connect your B3 to your wireless network

Post by tiddler » 23 Dec 2011, 15:33

what additional steps do you need to take so that wlan0 is up with firewall settings intact after a reboot?

tiddler
Posts: 32
Joined: 07 Apr 2009, 03:23

Re: Connect your B3 to your wireless network

Post by tiddler » 23 Dec 2011, 16:12

how could you bridge the ethernet connection when using the bubba3 as a wifi client?

thanks

Bultee
Posts: 6
Joined: 19 Jun 2011, 03:13

Re: Connect your B3 to your wireless network

Post by Bultee » 27 Jan 2012, 22:07

In response to gringo - I also get an error message that it can't find the wpasupplicant. I am trying to run this on a B2
Thanks

johannes
Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: Connect your B3 to your wireless network

Post by johannes » 18 Feb 2012, 06:43

added to the wiki, thanks a lot kenned!
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

Lone
Posts: 1
Joined: 21 Feb 2012, 00:20

Re: Connect your B3 to your wireless network

Post by Lone » 21 Feb 2012, 00:26

What was the work around for the aptitude issue.. I also cant install "wireless-tools" this way..

Code: Select all

root@b3:/home/lone# aptitude install wireless-tools
Couldn't find any package matching "wireless-tools".  However, the following
packages contain "wireless-tools" in their description:
  iw
Couldn't find any package matching "wireless-tools".  However, the following
packages contain "wireless-tools" in their description:
  iw
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
I would like to get my B3 working as a Wireless Client rather than Wireless AP
- Lone
Official B3+Tor Beta Tester

johannes
Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: Connect your B3 to your wireless network

Post by johannes » 21 Feb 2012, 02:54

Ok, updated the guide with more detail, let me know if it still doesn't work.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

Post Reply