Page 1 of 1

Checking disk temperature

Posted: 23 May 2007, 06:18
by johannes
The hard drive in your Bubba is the most sensitive part, it is recommended to keep the temperature as low as possible. According to the disk drive's data sheets, the operating temperature should not exceed 64°C (147°F) during operation, measured at the disk itself. However, keeping the temperature even lower will ensure a long life. Make sure that the ventilator openings on Bubba aren't covered, and don't place Bubba directly on top of or under other hot equipment.

All disk drives has built in temperature sensors. One way to check the temperature is to use the application hddtemp.


Using ssh, log on to Bubba (as your regular user). Type

Code: Select all

to become root. The root password is

Code: Select all

To reach the 'hddtemp' Debian package, we have to enable that repository. Type

Code: Select all

nano /etc/apt/sources.list
Uncomment the row saying

Code: Select all

#deb sarge main removing the # sign. Save and exit. To update the package lists, type:

Code: Select all

apt-get update
Now, to install, type

Code: Select all

apt-get install hddtemp
You will get a screen asking for some settings. Following the default choices works good.

Now, restore the sources.list file:

Code: Select all

nano /etc/apt/sources.list
Put back the comment on the line saying:

Code: Select all

deb sarge main
Save and exit.

Now you're done! To check the temperature, type:

Code: Select all

hddtemp /dev/hda
It should answer something like:

Code: Select all

/dev/hda: ST3160021A: 55 C
To allow for easier access to the temperature, you can always install phpsysinfo or other similar tools. This isn't in the scope of this guide however.

Error Message

Posted: 21 Jun 2007, 10:35
by wmnelis
Thanks for the info. I am interested in setting up my machine to tell me the drive temp automatically every time I log into it via ssh. I have successfully installed hddtemp via your instructions. However, when I run it I get the following error:

bubba:/dev# hddtemp /dev/hda
WARNING: Drive /dev/hda doesn't appear in the database of supported drives
WARNING: But using a common value, it reports something.
WARNING: Note that the temperature shown could be wrong.
WARNING: See --help, --debug and --drivebase options.
WARNING: And don't forget you can add your drive to hddtemp.db
/dev/hda: ST3320620A: 45 C or F

Any advice?

Also, I cannot seem to run this unless I am root. Is there a good way to set it up so I can run it as any user?


Posted: 21 Jun 2007, 11:21
by johannes
You can ignore the warning, it only states that your specific drive isn't in the hddtemp database. However, it tries to interpret the values read, and if you can read a reasonably correct value (as in your case), it works OK.

Regarding the root vs user rights I'm not the right person. Perhaps someone with more Linux knowledge can help out here?

Posted: 21 Jun 2007, 15:06
by Per
You drive is not present in the hddtemp database. You find this file in /etc/hddtemp.db. You should add a line repesenting you drive, look at the present entries and in hddtemp man page.

A typical entry is like this:

Code: Select all

"ST3500630A"                            194  C  "Seagate ST3500630A 500GB"
You should have a entry for ST3320620A. C is for celcius and the number is the SMART entry number.


Code: Select all

hddtemp -D /dev/hda
to see all SMART entries for you drive. Then you have to guess what entry is the temperature. The value that changes like a temperature reading is the one. On segate it probable is 194.

To be able to ru hddtemp as other user then root, you run

Code: Select all

dpkg-reconfigure hddtemp
as root and follow the questions.



Posted: 23 Jun 2007, 12:16
by wmnelis
Great! That worked perfectly. Thanks for the help Per.

Posted: 14 Feb 2008, 14:35
by Rawhead
I dont have the file /etc/hddtemp.db :( what 2 do

Posted: 15 Feb 2008, 21:00
by Cheeseboy
Hello Rawhead,

Did you follow the instructions on how to install it?
Did you get any error messages whilst installing it?

Do you get any hits if you type in this as root:

Code: Select all

find / -name hddtemp.db

Posted: 16 Feb 2008, 03:08
by Rawhead
Thanks I did solve this issue. dont know how but the file was there in the end. Me blind sometimes

URL Doesn't exist anymore?

Posted: 03 Jan 2009, 18:09
by Brulsturm
Apparently, at least 1 URL in the "sources.list" doesn't seem to exist anymore.
Because after the commando, "apt-get update", I get this errormessage:

"Failed to fetch ... rm/Release Temporary failure resolving ''
Failed to fetch ... ackages.gz Temporary failure resolving ''"

I tried this guide to install HDDtemp on my Bubba(1) several times and this message always shows up.

Internet connection is OK. Softwareversion on the Bubba is: 0.52.2-1

Any suggestions?

Thanks in advance.

solved: incorrect URL's in sources.list

Posted: 05 Jan 2009, 16:01
by Brulsturm
Thanks to some other part of the forum, I managed to get the APT working again; replaced the 3 upper lines with this one:

HTTP:// sarge main non-free

greetings, Brulsturm

Re: solved: incorrect URL's in sources.list

Posted: 31 Jan 2009, 19:27
by hastalapasta
Brulsturm wrote:Thanks to some other part of the forum, I managed to get the APT working again; replaced the 3 upper lines with this one:

HTTP:// sarge main non-free

greetings, Brulsturm
And which thread was that?