Problems after updating to version 1.0.13 [solved]

Got problems with your B2 or B3? Share and get helped!
Post Reply
Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Problems after updating to version 1.0.13 [solved]

Post by Binkem » 02 Jan 2009, 16:51

Hi all,

When updating to the latest version (1.0.13) there were some errors. I updated via Putty (Apt-get update and apt-get dist-upgrade), but since then my bubba still works as usual except for that the services tab on the admin web interface doesn't work anymore and that the update function (web based) doesn't work.
Trying to update using Putty gets the following results:
bubba:/home/# apt-get update
Get:1 http://ftp.se.debian.org etch Release.gpg [386B]
Hit http://ftp.se.debian.org etch Release
Ign http://ftp.se.debian.org etch/main Packages/DiffIndex
Hit http://ftp.se.debian.org etch/main Packages
Get:2 http://update.excito.org marielle Release.gpg [189B]
Get:3 http://update.excito.org upstream_etch Release.gpg [189B]
Get:4 http://update.excito.org marielle Release [2970B]
Get:5 http://update.excito.org upstream_etch Release [2651B]
Hit http://update.excito.org marielle/main Packages/DiffIndex
Hit http://update.excito.org upstream_etch/main Packages/DiffIndex
Fetched 6000B in 4s (1406B/s)
Reading package lists... Done
bubba:/home/# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages will be upgraded:
bubba-backend
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 35.3kB of archives.
After unpacking 32.8kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://update.excito.org marielle/main bubba-backend 1.0.18-7 [35.3kB]
Fetched 35.3kB in 0s (102kB/s)
Failed to fetch http://update.excito.org/pool/main/b/bu ... owerpc.deb Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
If i try the suggested --fix missing (last line of the above) I get:
bubba:/home/# apt-get dist-upgrade --fix-missing
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages will be upgraded:
bubba-backend
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 35.3kB of archives.
After unpacking 32.8kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://update.excito.org marielle/main bubba-backend 1.0.18-7 [35.3kB]
Fetched 35.3kB in 0s (88.9kB/s)
Failed to fetch http://update.excito.org/pool/main/b/bu ... owerpc.deb Size mismatch
Setting up bubba-horde (0.0.56) ...
dbconfig-common: writing config to /etc/dbconfig-common/bubba-horde.conf
Replacing config file /etc/horde/debian-db.php with new version
creating database backup in /var/cache/dbconfig-common/backups/bubba-horde_0.0.48.mysql.
dpkg: error processing bubba-horde (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
bubba-horde
E: Sub-process /usr/bin/dpkg returned an error code (1)
trying to reach the services tab on the web intergace gets me:
Fatal error: Call to undefined function is_installed() in /usr/share/web-admin/admin/system/application/controllers/services.php on line 37
and the update function returns:
Update software
Preparing to update system
Error: parsererror
Any suggestion (please?)

Martijn
Last edited by Binkem on 07 Jan 2009, 07:35, edited 1 time in total.

Hape
Posts: 53
Joined: 01 Nov 2008, 11:21

Post by Hape » 02 Jan 2009, 18:58

Doesn't look to be 1.0.13 to me?

Have you been editing /etc/apt/sources.list lately ?

rgds Hape

Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Post by Binkem » 03 Jan 2009, 15:55

Never edited that

Bubba says its on 1.0.13
Uptime 48 days 23:52:15
Version 1.0.13

Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Post by Binkem » 03 Jan 2009, 16:06

This is my sources.list. Please let me know if I should change anything.
# BUBBA|TWO apt sources.list
#
# Changes in this file might break your system
#
# vim: ft=debsources

# The stable BUBBA|TWO repository, is in the suite "stable".
deb http://update.excito.org/ marielle main

# The stable BUBBA|TWO repository, is in the suite "stable". source packages
#deb-src http://update.excito.org/ marielle main

# The upstream packages used in BUBBA|TWO, is in the suite "upstream_stable".
deb http://update.excito.org/ upstream_etch main

# The upstream packages used in BUBBA|TWO, is in the suite "upstream_stable". source packages
#deb-src http://update.excito.org/ upstream_etch main

# The debian etch repository containing unsupported packages that can be used.
deb http://ftp.se.debian.org/debian etch main

# The debian etch repository containing unsupported packages that can be used. source packages
#deb-src http://ftp.se.debian.org/debian etch main

# The debian etch repository containing unsupported packages that can be used.
#deb http://ftp.se.debian.org/debian etch contrib

# The debian etch repository containing unsupported packages that can be used. source packages
#deb-src http://ftp.se.debian.org/debian etch contrib

# The debian etch repository containing unsupported packages that can be used.
#deb http://ftp.se.debian.org/debian etch non-free

# The debian etch repository containing unsupported packages that can be used. source packages
#deb-src http://ftp.se.debian.org/debian etch non-free


# The unstable BUBBA|TWO repository, is in the suite "unstable".
#deb http://update.excito.org/ claire main

# The unstable BUBBA|TWO repository, is in the suite "unstable". source packages
#deb-src http://update.excito.org/ claire main

# The upstream packages used in unstable BUBBA|TWO, is in the suite "upstream_stable_forclaire".
#deb http://update.excito.org/ upstream_etch_forclaire main

# The upstream packages used in unstable BUBBA|TWO, is in the suite "upstream_stable_forclaire". source packages
#deb-src http://update.excito.org/ upstream_etch_forclaire main
[/quote]

Hape
Posts: 53
Joined: 01 Nov 2008, 11:21

Post by Hape » 03 Jan 2009, 19:01

You are right, no funny things in the source.list.

Just checked bubba-backend (after upgrading to 1.0.13) indeed checks out to be version 1.0.18-8. over here.

You might have a chance using aptitude, under the tree: Installed packages - admin - main -

or wait for an answer from Excito support, they probably can tell what went wrong and prevent any further hassle.

rgds

Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Post by Binkem » 07 Jan 2009, 07:40

My problem has been solved thanks to Carl of the Excito-crew. It turns out that I there had both been a partial,
failed download, which wasn't recovered and I had changed the MySQL password.

Clearing out the failed download was done by:
apt-get clean
rm -f /var/lib/apt/lists/update.excito.org_dists_*
apt-get update
apt-get dist-upgrade
the MySQL password was entered in
/var/cache/debconf/passwords.dat

I hope this may help others

Greeting Martijn

Post Reply