Sending email from mail.app not working

Got problems with your B2 or B3? Share and get helped!
Post Reply
jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Sending email from mail.app not working

Post by jamerson » 09 Mar 2009, 08:35

Hi!

I am sure that the answer lies here somewhere, but I have searched the forum without result...

My problem: I can send and receive fine with webmail. I can receive with mail.app (and probably thunderbird/outlook/etc). What I can't do is to send email from mail.app.
I guess is just a question of what authentication method I should use or something. But no matter what I try I can't get it to work.

Anyone?

/pelle

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 11 Mar 2009, 14:18

No one?

I am talking about Mac OSX Mail.

Someone must have got this working?!

/pelle

GaryL
Posts: 87
Joined: 04 Sep 2007, 17:40
Location: Northern Ireland

Post by GaryL » 12 Mar 2009, 16:14

I use Mail on my Mac/iPhone, but I push everything out through my ISP's SMTP server and not bubba.

What is your current outgoing server setup in Mail, What is Authentication set to, etc?

If you have your external domain name specified as your outgoing mail server in Mail or if you want to push outgoing mail through bubba outside of your LAN then you would need to make sure that your firewall has port 25 forwarded to bubba. Otherwise try using the local IP address of bubba as your outgoing server in Mail.

Gary
.

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 13 Mar 2009, 14:50

I have my bubba's LAN IP set as server name.

See images for further settings.

Image
Image

/pelle

GaryL
Posts: 87
Joined: 04 Sep 2007, 17:40
Location: Northern Ireland

Post by GaryL » 14 Mar 2009, 12:58

Uncheck "Use Secure Sockets Layer (SSL)" and it should work then.


Gary
.

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 14 Mar 2009, 14:21

Hi!

Tried that, still no luck :(

/pelle

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 14 Mar 2009, 14:26

mail.log says this:
Mar 14 18:20:15 bubba postfix/smtpd[21118]: connect from unknown[192.168.10.80]
Mar 14 18:20:15 bubba postfix/smtpd[21118]: NOQUEUE: reject: RCPT from unknown[192.168.10.80]: 554 5.7.1 <emailitry@tosend.to>: Relay access denied; from=<emailitry@tosend.from> to=<emailitry@tosend.to> proto=ESMTP helo=<[192.168.10.80]>
Mar 14 18:20:15 bubba postfix/smtpd[21118]: disconnect from unknown[192.168.10.80]
and 192.168.10.80 is in this case my mac.

/pelle

Xet
Posts: 53
Joined: 12 May 2008, 02:40

Post by Xet » 14 Mar 2009, 18:36

Bubba won't relay emails from external IP-adresses. More on why this is a good thing can be read at http://en.wikipedia.org/wiki/Open_mail_relay

As root add your LAN IP-range to the "mynetworks" attribute in the /etc/postfix/main.cf file and execute

Code: Select all

/etc/init.d/postfix restart

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 15 Mar 2009, 05:18

I read that some time ago, but did not manage to pull it off.
Exactly how should that line look (192.168.10.* is my LAN ip range)?

here's how it reads now:
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128

I don't understand all the arguments here ;)

Thanks for your help on this!

/pelle

Xet
Posts: 53
Joined: 12 May 2008, 02:40

Post by Xet » 15 Mar 2009, 08:23

In that case you should add 192.168.10.0/24.
Your line should look something like:

Code: Select all

mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 , 192.168.10.0/24

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 15 Mar 2009, 12:38

THANK YOU!

Post Reply