Wrong file timestamps?

Got problems with your B2 or B3? Share and get helped!
Post Reply
wil
Posts: 5
Joined: 29 Sep 2009, 07:17

Wrong file timestamps?

Post by wil » 18 Oct 2009, 15:30

I notice that file timestamps lack the microseconds part (i.e. set to 000000000)
See example below

Code: Select all

$ touch a
$ touch aa
$ touch aaa

$ stat a aa aaa
  File: `a'
  Size: 0               Blocks: 0          IO Block: 4096   regular empty file
Device: fd00h/64768d    Inode: 5914756     Links: 1
Access: (0666/-rw-rw-rw-)  Uid: ( 1001/     wil)   Gid: (  100/   users)
Access: 2009-10-18 20:44:14.000000000 +0200
Modify: 2009-10-18 20:44:14.000000000 +0200
Change: 2009-10-18 20:44:14.000000000 +0200
  File: `aa'
  Size: 0               Blocks: 0          IO Block: 4096   regular empty file
Device: fd00h/64768d    Inode: 5914757     Links: 1
Access: (0666/-rw-rw-rw-)  Uid: ( 1001/     wil)   Gid: (  100/   users)
Access: 2009-10-18 20:44:15.000000000 +0200
Modify: 2009-10-18 20:44:15.000000000 +0200
Change: 2009-10-18 20:44:15.000000000 +0200
  File: `aaa'
  Size: 0               Blocks: 0          IO Block: 4096   regular empty file
Device: fd00h/64768d    Inode: 5914758     Links: 1
Access: (0666/-rw-rw-rw-)  Uid: ( 1001/     wil)   Gid: (  100/   users)
Access: 2009-10-18 20:44:17.000000000 +0200
Modify: 2009-10-18 20:44:17.000000000 +0200
Change: 2009-10-18 20:44:17.000000000 +0200
Further information:

Code: Select all

$ uname -a
Linux bubba 2.6.26.5 #3 Thu Aug 6 14:46:56 CEST 2009 ppc GNU/Linux

$ cat /etc/bubba_version
300

$ cat /etc/bubba.version
1.2.3

carl
Posts: 474
Joined: 07 May 2008, 04:41

Re: Wrong file timestamps?

Post by carl » 19 Oct 2009, 12:08

I don't know if this is a problem; I can confirm this on the bubba, but also on two different desktops (one 32bit debian, and one 64bit ubuntu); I've been unable to locate an computer showing sub-second timestamps.

/carl
/Carl Fürstenberg, Excito Software Developer
http://www.excito.com
support@excito.com

acidtv
Posts: 14
Joined: 18 Oct 2009, 16:49

Re: Wrong file timestamps?

Post by acidtv » 19 Oct 2009, 13:22

Default debian installs don't seem to show subsecond timestamps by default.

Post Reply