B3 update kills fireplay

Got problems with your B2 or B3? Share and get helped!
beweb
Posts: 27
Joined: 22 May 2011, 15:33

B3 update kills fireplay

Post by beweb » 26 Jan 2012, 17:05

Hi,

Did an update yesterday of the B3 to version 2.3 and now the fireplay app doesn't work anymore.
Searched the forum and checked:
- server is running (restarted it a few times with no problem
- server-page on port 3689 works and shows 4009 songs available so it finds the songs.
- rebuild the songs3.db (size matches the old one)
- DLNA (uPnP) works on other device

So server is OK.

I think I saw the problem and it is in the (new?) link to fireplay.
When I'm in the admin interface and click the music icon I'm redirected to http://b3/admin/music
But the application says it's connecting to http://b3/music.
Manual loading of http://b3/music gives a 'Not found' message.
(source verifies this error:

Code: Select all

<embed src="/admin/views/default/music/FirePlay.swf?host=host=b3/music&port=&preventdownload=0">
.

My numbers after yesterday:
Package name Package version
bubba 2.3.2
bubba-album 2.4~pre2
bubba-backend 2.3.2.11
bubba-frontend 2.3.1
bubba3-kernel 2.6.38-1
filetransferdaemon 0.54
squeezecenter 7.6.1.dfsg1-2

Think this one has to be fixed.
Johannes, is this posible for the 2.4 version?

carl
Posts: 474
Joined: 07 May 2008, 04:41

Re: B3 update kills fireplay

Post by carl » 27 Jan 2012, 07:30

I've tested it now with a 2.4 installation, and it work perfectly :)
/Carl Fürstenberg, Excito Software Developer
http://www.excito.com
support@excito.com

GodfatherB
Posts: 55
Joined: 03 Jan 2012, 18:17

Re: B3 update kills fireplay

Post by GodfatherB » 27 Jan 2012, 07:52

It actually worked for me with 2.3.2... but now, since I upgraded to 2.4 it doesn't anymore.

As beweb said... it is connecting to http://b3/music and never connects.

carl
Posts: 474
Joined: 07 May 2008, 04:41

Re: B3 update kills fireplay

Post by carl » 27 Jan 2012, 08:35

GodfatherB wrote:It actually worked for me with 2.3.2... but now, since I upgraded to 2.4 it doesn't anymore.

As beweb said... it is connecting to http://b3/music and never connects.
I'm not certain what the problem might be, but it could be a remain of mt-daapd preventing forked-daapd to start; Could you try to reboot your B3 and see if it helps?
/Carl Fürstenberg, Excito Software Developer
http://www.excito.com
support@excito.com

GodfatherB
Posts: 55
Joined: 03 Jan 2012, 18:17

Re: B3 update kills fireplay

Post by GodfatherB » 27 Jan 2012, 09:15

I did not made a reset but I did turn off and then on again the DAAP in Services menu. This did the trick.

beweb
Posts: 27
Joined: 22 May 2011, 15:33

Re: B3 update kills fireplay

Post by beweb » 27 Jan 2012, 09:42

For me the restarting of the service didn't work.

Just a few minutes after my post the 2.4 was announced and I saw the new daap-server in it.
Maybe that will solve the whole problem.

So, at this moment it is updating ....
Connection lost ....
Connenction back ...

New numbers:
bubba 2.4
bubba-album 2.4
bubba-backend 2.4
bubba-frontend 2.4.0.2
bubba3-kernel 1:2.6.39.4-9
filetransferdaemon 0.54
logitechmediaserver 7.7.1.dfsg1-7

Restarting ....

NO, still the same problem.
Link to /admin/music and tries to connecting to /music

Any suggestions?

carl
Posts: 474
Joined: 07 May 2008, 04:41

Re: B3 update kills fireplay

Post by carl » 27 Jan 2012, 11:02

beweb wrote:For me the restarting of the service didn't work.

Just a few minutes after my post the 2.4 was announced and I saw the new daap-server in it.
Maybe that will solve the whole problem.

So, at this moment it is updating ....
Connection lost ....
Connenction back ...

New numbers:
bubba 2.4
bubba-album 2.4
bubba-backend 2.4
bubba-frontend 2.4.0.2
bubba3-kernel 1:2.6.39.4-9
filetransferdaemon 0.54
logitechmediaserver 7.7.1.dfsg1-7

Restarting ....

NO, still the same problem.
Link to /admin/music and tries to connecting to /music

Any suggestions?
Make sure you haven't modified or made any alterations to the apache site configuration. in the site configuration for port 80, there should be a proxy definition as following:

Code: Select all

        <Proxy *>
                Order deny,allow
                Allow from all
        </Proxy>
        ProxyPass /music http://localhost:3689
        ProxyPassReverse /music http://localhost:3689
/Carl Fürstenberg, Excito Software Developer
http://www.excito.com
support@excito.com

beweb
Posts: 27
Joined: 22 May 2011, 15:33

Re: B3 update kills fireplay

Post by beweb » 27 Jan 2012, 14:30

Carl,

That could be a good tip.
One question. I'm always lost in linux with 502.. almost identical configuration files.
To be sure, do you mean this one: /etc/apache2/conf.d/name-vhosts.conf
...
never mind .. it works ..right file this time

Tanx carl for the tip

nolla
Posts: 22
Joined: 11 Mar 2011, 13:16
Location: Turku, Finland

Re: B3 update kills fireplay

Post by nolla » 03 Apr 2012, 18:01

I have had some problems with bubba2 2.4 version too.

By looking into forked-daap's logs I found out that avahi-daemon blocks daaps starting.

Code: Select all

nolla@bubba:~$ tail -f /var/log/forked-daapd.log
[2012-04-04 00:46:27]     mdns: Failed to create service browser: Bad state
[2012-04-04 00:46:27]   player: Could not add mDNS browser for AirTunes devices
[2012-04-04 00:46:27]     main: Player thread failed to start
When starting avahi-daemon I get a warning like this:

Code: Select all

Starting Avahi mDNS/DNS-SD Daemon: avahi-daemonavahi-daemon disabled because there is a unicast .local domain ... (warning).
By deleting

Code: Select all

/var/run/avahi-daemon/disabled-for-unicast-local
I finally get the Fireplay to connect. I also have the port 3689 opened.

Fireplay works well, but services web menu does not work. I can switch off services but not getting them to run. I have to start them via terminal.

urbaxe
Posts: 7
Joined: 06 Jan 2009, 15:00
Contact:

Re: B3 update kills fireplay

Post by urbaxe » 28 May 2012, 16:54

Is there any progress in this case?

johannes
Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: B3 update kills fireplay

Post by johannes » 29 May 2012, 06:23

Yes, this is solved since 2.4.2, so just updating to latest should do the trick. If it doesn't please let us know.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

gonk
Posts: 93
Joined: 30 May 2012, 01:53

Re: B3 update kills fireplay

Post by gonk » 03 Jun 2012, 11:37

johannes wrote:Yes, this is solved since 2.4.2, so just updating to latest should do the trick. If it doesn't please let us know.
I bought my B3 this week and updated it to 2.4.2 but then had to switch hardware due to gigabit problems.
When I finally got to copy some music to the B3 (now running 2.5) I get similar problems as mentioned in this thread.
Observations:
  • I've nor made any changes to any config files related to DNLA or music.
  • The music icon on b3/admin links to b3/admin/music
  • When b3/admin/music has loaded its flash based interface there's the text "Connecting to http://b3/music" in the middle of the top of the page.
    No music is played and no genres, artists, albums or songs are listed.
  • Using the HTTP-sniffer Fiddler I see that a request is made to /music/rsp/info but it results in a HTTP 503 Service Temporarily Unavailable.
    The referer value for that request is b3/admin/views/default/music/FirePlay.swf?host=b3/music&port=&preventdownload=0
If the music player doesn't work as delivered out-of-the-box from you then there is a problem and I'm not happy about it.

johannes
Posts: 1470
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Re: B3 update kills fireplay

Post by johannes » 04 Jun 2012, 09:47

Strange. Did you make any changes related to apache or it's config? (I am asking since I know it's working out of the box, just tried, so something must have happened..)
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

stig
Posts: 1
Joined: 24 Nov 2012, 05:07

Re: B3 update kills fireplay

Post by stig » 24 Nov 2012, 05:27

I have the same problem on my B3 with software version 2.5.1.2.
I have not tried FirePlay before so I do not know if it did work in previous versions.
No changes have been made to the apache files or configuration. FirePlay tries to connect to b3/music but no songs are listed at all. All songs are available when connecting to B3 in Windows Media Player on my PC.

a1n
Posts: 18
Joined: 18 Jan 2011, 05:41
Location: Netherlands

Re: B3 update kills fireplay

Post by a1n » 15 Jul 2013, 09:15

Hi I have the same problem as described by gonk. My software version is 2.6 on a B3.

Please help.
/a1n

Post Reply