Problems with RPC ports for NFS

Got problems with your B2 or B3? Share and get helped!
Post Reply
Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Problems with RPC ports for NFS

Post by Clive » 18 Jun 2012, 02:58

Hi Guys,

I have started trying to configure my B3 to act as a boot server for my Raspberry Pi. However, I have run into some strange issues regarding the ports on the B3 after installing and configuring NFS.

Installing NFS orginally worked fine and I was able to connect, however after a B3 reboot last week, nothing I would do would enable my RPi to connect to it via NFS. Issuing 'rpcinfo -p B3' just hung until it timed out minutes later.

Lots and lots of Googling later I discovered that I had to allow the B3 to manually open the ports used for NFS.

So from my B3 I issued the command -

rpcinfo -p

and then after opened the associated ports with -

iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 2049 -j ACCEPT

However, the ports do change after a B3 reboot or restart of nfs-server-common. Does anyone know why I need to do this and is there a permanant fix ??

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Re: Problems with RPC ports for NFS

Post by Clive » 18 Jun 2012, 03:52

In fact, has anyone any ideas why 'iptables' is running on the B3 at all ? I am not using my B3 as a router and it is sat behind my ADSL router which is handling all the port forwarding and stuff.

Would it be safe to switch iptables off in this situation ?

Gordon
Posts: 1356
Joined: 10 Aug 2011, 03:18

Re: Problems with RPC ports for NFS

Post by Gordon » 18 Jun 2012, 05:09

It is possible to set fixed ports for NFS - check this wiki.

Don't know why bubba-firewall would be running in your setup - did you choose the correct profile on your B3? To answer your question: yes, it should be safe enough to run without a firewall in a trusted environment.

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Re: Problems with RPC ports for NFS

Post by Clive » 18 Jun 2012, 05:21

Perfect ! Thanks !

It may be that by Bubba thinks it's acting as a router, strangely when I just now attempted to login to admin to check, I got the message -

"Admin user not allowed to login on WAN interface. Please read the users manual for advice. "

...which is strange as it allowed me to do this last week. Also, when my ADSL router goes down, my B3 seems to think it should take up the routing role, which causes no ends of arguments when the router comes back up.

EDIT - More thinking, the above message seems to suggest I have the router plugged into the wrong port on the B3 which could have happened when I reached round the back of it a few days back to temporarily pull the ethernet cable. DOH!

ingens
Posts: 4
Joined: 05 Jan 2010, 23:37

Re: Problems with RPC ports for NFS

Post by ingens » 08 Jul 2012, 18:49

Hello Clive,

recently I tried a similar thing, at first I had problems to set the ports for rpc.lockd. Maybe this post is useful for you: http://forum.excito.net/viewtopic.php?f=9&t=3920

Post Reply