2.5.1.2 Web interface errors [Solved]

Got problems with your B2 or B3? Share and get helped!
Post Reply
PerN
Posts: 28
Joined: 20 May 2010, 15:07

2.5.1.2 Web interface errors [Solved]

Post by PerN » 28 Jan 2013, 15:13

Hi,

after upgrading my B2 to 2.5.1.2 (using the System update feature in the web interface) the web interface is broken, producing numerous javascript errors such as (but not limited to)
"Message: Object doesn't support this property or method
Line: 76
Char: 4
Code: 0
URI: http://b2/admin/views/default/_js/main.js?v='2.5.1.6'"

when I for example try to add a new user.
Pretty much all functionality seems to be broken. I can log on to Administration using IE (chrome doesn't work), but that is about all I can do.

I re-installed to 2.4.1 and then it all worked fine again.
I upgraded using "apt-get dist-upgrade" to see if that worked better, but no, the web was broken again.

Have I stupidely missed something?
Last edited by PerN on 31 Jan 2013, 15:06, edited 1 time in total.

nobody
Posts: 226
Joined: 10 Mar 2012, 14:46

Re: 2.5.1.2 Web interface errors

Post by nobody » 28 Jan 2013, 15:32

I tried to reproduce but cannot get these errors. Would you be able to show output from the apache logs?

PerN
Posts: 28
Joined: 20 May 2010, 15:07

Re: 2.5.1.2 Web interface errors

Post by PerN » 28 Jan 2013, 15:57

nobody wrote:I tried to reproduce but cannot get these errors. Would you be able to show output from the apache logs?
Here's a snippet from the access log.

Code: Select all

192.168.10.89 - - [28/Jan/2013:20:52:40 +0000] "POST /admin/users/edit_user_account/json HTTP/1.1" 200 421 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:40 +0000] "GET /admin/users HTTP/1.1" 200 4974 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_css/jquery.ui.theme.default.css?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.js?v='2.5.1.6' HTTP/1.1" 304 214 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.ba-resize.js?v='2.5.1.6' HTTP/1.1" 304 211 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/additional-methods.js?v='2.5.1.6' HTTP/1.1" 304 211 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.sprintf.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery-ui.js?v='2.5.1.6' HTTP/1.1" 304 214 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.validate.js?v='2.5.1.6' HTTP/1.1" 304 211 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/Gettext.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/locale/en/LC_MESSAGES/bubba.json?v='2.5.1.6' HTTP/1.1" 304 187 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.ui.throbber.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.pubsub.js?v='2.5.1.6' HTTP/1.1" 304 209 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_css/admin.css?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.iCheckbox.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/main.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.jclock.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/user.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/coolclock.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.ba-resize.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.validate.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/additional-methods.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.ui.throbber.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.pubsub.js?v='2.5.1.6' HTTP/1.1" 304 209 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.sprintf.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/locale/en/LC_MESSAGES/bubba.json?v='2.5.1.6' HTTP/1.1" 304 187 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/Gettext.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/coolclock.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.jclock.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/jquery.iCheckbox.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/main.js?v='2.5.1.6' HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_js/user.js?v=2.5.1.6 HTTP/1.1" 304 210 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:41 +0000] "GET /admin/views/default/_img/logo.png HTTP/1.1" 304 186 "http://bubba/admin/" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:48 +0000] "GET /admin/settings HTTP/1.1" 200 4416 "http://bubba/admin/users" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"
192.168.10.89 - - [28/Jan/2013:20:52:53 +0000] "GET /admin/settings/logs HTTP/1.1" 200 4754 "http://bubba/admin/settings" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17"

nobody
Posts: 226
Joined: 10 Mar 2012, 14:46

Re: 2.5.1.2 Web interface errors

Post by nobody » 30 Jan 2013, 13:58

sorry, I need the error log

PerN
Posts: 28
Joined: 20 May 2010, 15:07

Re: 2.5.1.2 Web interface errors

Post by PerN » 31 Jan 2013, 15:05

It seem to have sorted itself out after I made sure to clear the browsers' caches.
I guess it inconsistently mixed new files with olds.

Post Reply