Is Easyfind down?

Got problems with your B2 or B3? Share and get helped!
wm.bubba
Posts: 82
Joined: 11 May 2009, 12:58

Re: Is Easyfind down?

Post by wm.bubba » 07 Dec 2014, 04:03

Thanks Ubi,

Confirmed both NS1 and NS2 now hold the same IP address:

Code: Select all

wies@b2:~$ host -s ###.myownb2.com ns1.mybubba.org
Using domain server:
Name: ns1.mybubba.org
Address: 95.170.90.16#53
Aliases: 
###.myownb2.com has address ###.###.7.45

Code: Select all

wies@b2:~$ host -s ###.myownb2.com ns2.mybubba.org
Using domain server:
Name: ns2.mybubba.org
Address: 95.170.90.19#53
Aliases: 
###.myownb2.com has address ###.###.7.45

OlivierC
Posts: 31
Joined: 21 Sep 2013, 08:01

Re: Is Easyfind down?

Post by OlivierC » 07 Dec 2014, 09:32

Still not working for me
same problem as explained by kruemelprinz

DSL modem shut down to force WAN IP renewal.

syslog

Code: Select all

Dec 7 15:08:57 b3 kernel: [1731217.033084] mv643xx_eth_port mv643xx_eth_port.0: eth0: link up, 100 Mb/s, full duplex, flow control disabled
Dec 7 15:08:57 b3 ifplugd(eth0)[1144]: Link beat detected.
Dec 7 15:09:01 b3 /USR/SBIN/CRON[24443]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete)
Dec 7 15:09:13 b3 kernel: [1731233.578793] mv643xx_eth_port mv643xx_eth_port.0: eth0: link down
Dec 7 15:09:14 b3 ifplugd(eth0)[1144]: Link beat lost.
Dec 7 15:09:15 b3 kernel: [1731235.327985] mv643xx_eth_port mv643xx_eth_port.0: eth0: link up, 100 Mb/s, full duplex, flow control disabled
Dec 7 15:09:15 b3 ifplugd(eth0)[1144]: Link beat detected.
Dec 7 15:10:01 b3 /USR/SBIN/CRON[24454]: (root) CMD (/etc/init.d/dovecot status >/dev/null 2>&1 || /etc/init.d/dovecot restart)
Dec 7 15:10:01 b3 /USR/SBIN/CRON[24455]: (root) CMD (test -x /usr/bin/php && /usr/bin/php /usr/share/horde3/scripts/alarms.php)
Dec 7 15:10:01 b3 /USR/SBIN/CRON[24456]: (root) CMD (test -x /usr/lib/web-admin/notify-dispatcher.pl && /usr/lib/web-admin/notify-dispatcher.pl)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] Unhandled Error
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011Traceback (most recent call last):
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/dist-packages/twisted/web/_newclient.py", line 1034, in _bodyDataFinished_CONNECTED
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 self._bodyProtocol.connectionLost(reason)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/share/bubba-backend/bubba-easyfind.tac", line 55, in connectionLost
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 self.deferred.callback(self.string_io.getvalue())
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 368, in callback
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 self._startRunCallbacks(result)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 464, in _startRunCallbacks
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 self._runCallbacks()
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011--- <exception caught here> ---
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 551, in _runCallbacks
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 current.result = callback(current.result, *args, **kw)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/share/bubba-backend/bubba-easyfind.tac", line 102, in easyfind_ip_changed
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 decoded = json.loads(data)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/json/__init__.py", line 307, in loads
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 return _default_decoder.decode(s)
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/json/decoder.py", line 319, in decode
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 obj, end = self.raw_decode(s, idx=_w(s, 0).end())
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 File "/usr/lib/python2.6/json/decoder.py", line 338, in raw_decode
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011 raise ValueError("No JSON object could be decoded")
Dec 7 15:10:01 b3 twisted: [HTTP11ClientProtocol,client] #011exceptions.ValueError: No JSON object could be decoded
Dec 7 15:10:30 b3 bubba-networkmanager: Starting up
Dec 7 15:11:01 b3 twisted: [HTTP11ClientProtocol,client] Got new IP '81.51.61.250' which is not the same as the last one '81.51.60.56'
under web GUI
settings > Identity > Update Easyfind

return message:
Update successfull

dig -t ns myownb3.com
; <<>> DiG 9.10.1 <<>> -t ns myownb3.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61671
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1460
;; QUESTION SECTION:
;myownb3.com. IN NS

;; Query time: 46 msec
;; SERVER: 192.168.10.1#53(192.168.10.1)
;; WHEN: Sun Dec 07 15:27:13 Romance Standard Time 2014
;; MSG SIZE rcvd: 40
grep '^ip' /etc/network/easyfind.conf | awk {'print $3'}
81.51.61.250
wget -o /dev/null -O /dev/stdout http://ef.excito.org/ip.json
{"ip_address":"81.51.61.250"}

MouettE
Site admin
Posts: 284
Joined: 06 Oct 2011, 19:45

Re: Is Easyfind down?

Post by MouettE » 07 Dec 2014, 13:33

Ubi wrote:You did not get an answer, This means your local DNS server (192.168.1.254) is buggered. You should get this:

Code: Select all

[root@php-sites ~]# dig -t ns myownb3.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6 <<>> -t ns myownb3.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43818
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;myownb3.com.			IN	NS

;; ANSWER SECTION:
myownb3.com.		86400	IN	NS	ns2.mybubba.org.
myownb3.com.		86400	IN	NS	ns1.mybubba.org.

;; Query time: 53 msec
;; SERVER: 80.69.67.66#53(80.69.67.66)
;; WHEN: Wed Dec  3 20:57:12 2014
;; MSG SIZE  rcvd: 76
if 192.168.1.254 is your router, then you need to go to another forum, or start another thread. This is not an easyfind problem so for clarity sake lets not continue here.
I have the same problem here. This does not come from the router but from the ISP DNS servers who for whatever reasons give a SERVFAIL when asking about myownb3.com. kloth.net dns doesn't work either but google dns answer correctly. Perhaps the propagation is slow but it's been a few days now...

Ubi
Posts: 1547
Joined: 17 Jul 2007, 09:01

Re: Is Easyfind down?

Post by Ubi » 07 Dec 2014, 15:24

ah this could be because you only changed the records in the zone file, but did not specifically change them at he registrar as well. For .com domains this is sometimes necessary.

MouettE
Site admin
Posts: 284
Joined: 06 Oct 2011, 19:45

Re: Is Easyfind down?

Post by MouettE » 07 Dec 2014, 15:32

DNS is still somewhat mysterious to me... The whois record for the domain shows correct nameservers so I guess the registrar this ok ? Could it be the other way round, the zone file being incorrect ? We still running on the original Excito registrar (loopia) but the administration interface is not very clear. I'm going to dig a little deeper ...

kruemelprinz
Posts: 17
Joined: 05 May 2010, 16:53

Re: Is Easyfind down?

Post by kruemelprinz » 08 Dec 2014, 07:59

Hi again,

meanwhile I figured out the problem why my router's IP appeared instead of an "external" DNS, but that was my fault - had entered the router's IP as DNS also in the B3's network settings. Changed that to Googles DNS just to test if it would get working.

@OliverC: Try to check your B3's LAN settings and check you have entered a valid "external" DNS or if you have 192.168.10.1 in the DNS row.

/usr/lib/web-admin/easyfind.pl returns

Code: Select all

{"opcode":1,"record":{"domain_id":"1","content":"92.32.224.117","name":"suseundrobert.myownb3.com","type":"A","id":"2161"},"error":false,"operation":"IPupdate"}
and when I dig -t ns myownb3.com, the following reply occurs

Code: Select all

; <<>> DiG 9.7.3 <<>> -t ns myownb3.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64772
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;myownb3.com.			IN	NS

;; ANSWER SECTION:
myownb3.com.		21599	IN	NS	ns2.mybubba.org.
myownb3.com.		21599	IN	NS	ns1.mybubba.org.

;; Query time: 246 msec
;; SERVER: 8.8.4.4#53(8.8.4.4)
;; WHEN: Mon Dec  8 13:43:25 2014
;; MSG SIZE  rcvd: 76

So for my understanding, this looks good and should be indicative of a working system. But somehow I still cannot ping my easyfind adress. Same as for MouettE, i suppose.

Gordon
Posts: 1390
Joined: 10 Aug 2011, 03:18

Re: Is Easyfind down?

Post by Gordon » 08 Dec 2014, 10:29

That's normal. Ping (ICMP type 8) is not enabled in the firewall.

Also, requesting the name servers for the myownb3 domains does not tell you that it works. Most DNS servers will in fact not use that information and simply go upstream to retrieve records that they don't own themselves. Similar to what DNSmasq on your B3 does. If however you get invalid info from this (i.e. ns?.excito.org) it does tell you that the DNS server you are using is not receiving proper updates and you should probably switch to another.

Use `host` to find the address that is assigned to your myownb?.com. If you think the answer is wrong you can add a second parameter to specify an alternate DNS server you want to query for your address.

Example:
- host yourname.myownb3.com 8.8.8.8 (Google Public DNS)
- host yourname.myownb3.com ns1.mybubba.org (Authoritative - primary)
- host yourname.myownb3.com ns2.mybubba.org (Authoritative - secondary)
Last edited by Gordon on 09 Dec 2014, 05:46, edited 2 times in total.

OlivierC
Posts: 31
Joined: 21 Sep 2013, 08:01

Re: Is Easyfind down?

Post by OlivierC » 08 Dec 2014, 11:31

Without having changed anything on my side, it's working fine now.

kruemelprinz
Posts: 17
Joined: 05 May 2010, 16:53

Re: Is Easyfind down?

Post by kruemelprinz » 09 Dec 2014, 03:31

Gordon wrote:Example:
- host yourname.myownb3.com 8.8.8.8 (Google Public DNS)
- host yourname.myownb3.com ns1.myownb3.org (Authoritative - primary)
- host yourname.myownb3.com ns2.myownb3.org (Authoritative - secondary)
I have tested this and in the Google Public DNS I get the correct IP:

Code: Select all

host ***.myownb3.com 8.8.4.4
Using domain server:
Name: 8.8.4.4
Address: 8.8.4.4#53
Aliases: 

***.myownb3.com has address 92.*.*.117
Whereas ns1.myownb3.org and ns2.myownb3.org are unable to resolve the name:

Code: Select all

host ***.myownb3.com ns1.myownb3.org
host: couldn't get address for 'ns1.myownb3.org': not found

host ***.myownb3.com ns2.myownb3.org
host: couldn't get address for 'ns2.myownb3.org': not found
If google Public DNS can resolve the name to the correct IP (and I have Googles 8.8.8.8 and 8.8.4.4 set up as DNS in my router/modem's settings), why can't I reach my B3 by typing ***.myownb3.com, then? Seems mysterious... Any further testing suggestions to figure out the problem are much appreciated...

I also tried to switch of the modem and restart in order to get a new IP assigned, but I am stuck with my old one that I have had some weeks now. However I do not have the same IP as long time to make easyfind pointless.

Gordon
Posts: 1390
Joined: 10 Aug 2011, 03:18

Re: Is Easyfind down?

Post by Gordon » 09 Dec 2014, 05:45

My bad. And it wasn't even morning when I posted that, although it was a Monday.

It's mybubba.org, not myownb3.org. Fixed in original posting

Gordon
Posts: 1390
Joined: 10 Aug 2011, 03:18

Re: Is Easyfind down?

Post by Gordon » 09 Dec 2014, 06:03

kruemelprinz wrote: If google Public DNS can resolve the name to the correct IP (and I have Googles 8.8.8.8 and 8.8.4.4 set up as DNS in my router/modem's settings), why can't I reach my B3 by typing ***.myownb3.com, then? Seems mysterious... Any further testing suggestions to figure out the problem are much appreciated...

I also tried to switch of the modem and restart in order to get a new IP assigned, but I am stuck with my old one that I have had some weeks now. However I do not have the same IP as long time to make easyfind pointless.
From where to where are you trying to get to your B3 using its myownb3.com name? Are you outside, e.g. at work, or are you on the same LAN as the B3? In the latter case this is a router issue. You cannot DNAT back in using the same router that you used to get to your public address. The router must therefore have special rules to route back some of the outbound traffic if the destination is its own WAN address. If it doesn't support this, it will never work this way and your only option is to add the names and addresses to your hosts file(s).

86ivar
Posts: 148
Joined: 02 Oct 2010, 11:08

Re: Is Easyfind down?

Post by 86ivar » 09 Dec 2014, 09:43

Easyfind was not working for me yesterday or the day before. But now it is. Still using the myownb2.com. Is it changing to mybubba.org?

kruemelprinz
Posts: 17
Joined: 05 May 2010, 16:53

Re: Is Easyfind down?

Post by kruemelprinz » 09 Dec 2014, 13:58

Gordon wrote:From where to where are you trying to get to your B3 using its myownb3.com name? Are you outside, e.g. at work, or are you on the same LAN as the B3? In the latter case this is a router issue.
As in my earlier posts, I tried from both within the same LAN as the B3 but ALSO using my cellphone via 4G, where I have a totally different IP.
I reran the host call with the mybubba.org nameservers below, from the cellphone, outside my B3's LAN.

Code: Select all

host ****.myownb3.com ns1.mybubba.org
Using domain server:
Name: ns1.mybubba.org
Address: 95.170.90.16#53
Aliases: 

****.myownb3.com has address 92.*.*.117


host ****.myownb3.com ns2.mybubba.org
Using domain server:
Name: ns2.mybubba.org
Address: 95.170.90.19#53
Aliases: 

****.myownb3.com has address 92.*.*.117


host ****.myownb3.com 8.8.4.4
Using domain server:
Name: 8.8.4.4
Address: 8.8.4.4#53
Aliases: 

****.myownb3.com has address 92.*.*.117
It shows the correct 92.*.*.117 all the times but still I won't be able to open http://****.myownb3.com. Android browser keeps givning the error message "Website not available", followed by a line stating the following:

Code: Select all

net::ERR_NAME_NOT_RESOLVED
However, when i type the IP directly, i can access my owncloud and the B3 admin page. So port forwarding to the B3 does not seem to be the problem.

Gordon
Posts: 1390
Joined: 10 Aug 2011, 03:18

Re: Is Easyfind down?

Post by Gordon » 10 Dec 2014, 04:19

According to this web page you can't normally choose which DNS you want to use when on 4G. So yes you can verify that the authoritative servers and Google Public DNS point to the correct location, but the one that DHCP assigned to your phone fails to look up the address.

Please do note that it is pointless to set the authoritative servers as your DNS servers. They will only serve myownb2.com and myownb3.com and nothing else.

If you can root your phone (I tried rooting mine once, but it still blocked everything I wanted to do) then the page I linked to may solve your issue. If you can't, you should contact your provider and have them fix it on their DNS.

PS Did you try flush the DNS cache on your phone?

kruemelprinz
Posts: 17
Joined: 05 May 2010, 16:53

Re: Is Easyfind down?

Post by kruemelprinz » 12 Dec 2014, 14:36

Hi again,

I now tried from completely different PCs at work and cannot reach my easyfind-adress on any of them, but if I type the IP directly, everything is fine. Still seems to be a DNS problem, but I tried to check DNS records using some different nameservers, and all said that my adress pointed at my current IP adress.

Strange, but seems as if a new thread somewhere else is more suitable to help solve the issue.
Thanks for all comments and help!

Post Reply