How do I change max active downloads in downloader?

Got problems with your B2 or B3? Share and get helped!
Post Reply
86ivar
Posts: 148
Joined: 02 Oct 2010, 11:08

How do I change max active downloads in downloader?

Post by 86ivar » 09 Dec 2014, 09:39

I wonder if there is some way to alter the max active downloads settings. Right now I think it is max 2 or something. Whe the active torrents is not downloading due to no peers I want the downloader to start downloading the other ones.
Anyone had luck installing Transmission on B2 by the way?

Gordon
Posts: 1390
Joined: 10 Aug 2011, 03:18

Re: How do I change max active downloads in downloader?

Post by Gordon » 09 Dec 2014, 10:54

I have done it on a B3. The steps should be similar.

You can try install `transmission-daemon` from the repository and see if that works for you. If you want a newer version then you should read this thread where I explained what I did to get version 2.77 running.

86ivar
Posts: 148
Joined: 02 Oct 2010, 11:08

Re: How do I change max active downloads in downloader?

Post by 86ivar » 09 Dec 2014, 13:42

Ahh, I think I installed transmission and not transmission-daemon last time. I never got it to work.
Now it is working, thank you! :D

Edit: I was trying to set the password by commanding transmission-daemon -v --password. However this is not the password for the web interface cause that never changed even I restarted the daemon. I edited the settings.json file in /etc/transmission-daemon but that file is rewritten everytime I restart the daemon.
Did you solve this issue?

wm.bubba
Posts: 82
Joined: 11 May 2009, 12:58

Re: How do I change max active downloads in downloader?

Post by wm.bubba » 09 Dec 2014, 17:26

You need to stop transmission running before you edit the settings.json file, using

/etc/init.d/transmission-daemon stop

now make your changes to settings.json, and restart the daemon, using

/etc/init.d/transmission-daemon start

Post Reply