Arch: WAN interface does not go up automatically

Got problems with your B2 or B3? Share and get helped!
Post Reply
stasheck
Posts: 107
Joined: 15 Jan 2014, 13:13

Arch: WAN interface does not go up automatically

Post by stasheck » 22 Aug 2016, 03:33

I've got a minor issue with my Arch install: if the WAN interface is down when booting, it will not go "up" even after something is connected to it (so after apartment power loss, if B3 boots before cable modem, it will not go online). I've run out of ideas where to look for the reason of this behavior... Can someone point me into right direction?

sakaki
Posts: 172
Joined: 15 Aug 2014, 11:20

Re: Arch: WAN interface does not go up automatically

Post by sakaki » 22 Aug 2016, 17:43

Hi stasheck,

if you are using the arch live-USB (v1.2) it is configured to use systemd-networkd on eth0. If you are only concerned about a race condition on a forced power-cycle, and willing to wait for eth0 to come up, you could use:

Code: Select all

[root@archb3 ~]# systemctl enable systemd-networkd-wait-online.service
See this post for further discussion.

hth, sakaki

stasheck
Posts: 107
Joined: 15 Jan 2014, 13:13

Re: Arch: WAN interface does not go up automatically

Post by stasheck » 23 Aug 2016, 04:57

Thanks a lot, I'll try this :-)

Post Reply