Setting up a B3 miniserver

Got problems with your B2 or B3? Share and get helped!
Post Reply
Posts: 38
Joined: 01 Feb 2009, 15:25

Setting up a B3 miniserver

Post by beatgr » 21 Apr 2018, 12:10

I purchased an Excito B3 miniserver with Wireless option from eBay reseller netdiskountsdeals (Mr. David Gates) of Highland Park, NJ. The eBay price is extremely attractive for North American buyers.
This B3 miniserver is New Old Stock (NOS) without hard drive or rescue USB flash drive.
Based on hard drive rail marks, it appears this unit originally had a hard drive - which was removed.

Once you have your B3 miniserver (with Wireless LAN),
you need to decide which linux distribution you desire to use.
Initially, for testing your B3, I recommend using a live-USB image.
These can be found in Development section of Excito Forum.

Sakaki developed many Live-USB choices (GitHub).
Redsleeve(7) :
Since the history or mfg. date of this B3 was unknown, I updated the B3 bootloader to support 3 TB disks. ... _3TB_disks

I decided to use Gordon’s bubbagen image (gentoo with B3 webUI), systemd init type. ... /

SanDisk Cruzer Fit 16GB USB Flash Drive was chosen for the live-USB image.
I used my desktop computer (Win10) to prepare this new flash drive.

1.) Remove (or move) all files from the flash drive.
2.) Format the flash drive as FAT (FAT32 is fine).
3.) Install on your Windows PC an archival tool that supports “xz” images. I used 7-Zip.
4.) Download desired “xz” image from GitHub, saving to your local PC hard drive.
5.) Insert the prepared flash drive in the Windows PC USB port. Assure it has a drive letter assigned.
6.) Extract the “xz” image to the flash drive. My extraction utility took 22 minutes to perform this step.

So, now I have a bootable, live-USB image of Bubbagen, “systemd” version.

Per Gordon’s instructions, the B3 booted Gentoo (sakaki) with Excito webUI (gordon).
After a few minutes, the B3 was operational — with its LAN port (eth1) attached to my home network.
The Excito webUI (http, port 80) was accessible by computers/tablets on my home network.

Using Gordon’s patched Excito webUI, log-in as administrator (admin).
Go to the Settings menu, Time and Language sub-menu, for changing the time zone, date, and time.
For this Excito B3 miniserver I installed a new Western Digital NAS “Red” 3 TB hard drive.
The Bubbagen (GitHub) section, Installing Bubbagen on your B3's Internal Drive (Optional),
did not work as expected. I assume the script could not handle a blank 3 TB hard drive (no partitions)

So, logged in as “root” to the Bubbagen “Live” USB image — to use the parted application.
This utility offers a simple interface for partitioning disks and supports very large partitions (more than 2 TB), using 64-bit identifiers for the partitions — GPT (GUID Partition Table).

The Gentoo parted example, /dev/sda , is perfect for this B3 miniserver.
It is recommended to ask parted to use optimal partition alignment.
root # parted -a optimal /dev/sda
GNU Parted 2.3
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
Next, we use parted, to put a GPT label on the disk (/dev/sda).
Warning: Changing the partition type will remove all partitions from the disk. All data on the disk will be lost.
(parted) mklabel gpt
Continuing under the “parted” command, create four (4) partitions on this hard drive as shown in example. ... n_the_disk

After creating these GPT partitions on the 3 TB drive, I re-tried Gordon’s script for installing Bubbagen.
This time the script ran, as expected.

I shutdown the B3, removed power, and removed the live-USB flash drive.
Reconnecting DC power, the B3 mini-server booted up after about 90-100 seconds, with solid Blue LED.
There were some false starts: Ethernet cable not fully inserted into home network hub, B3 seemed to not boot the hard drive Gentoo image (took longer than Gordon noted)
Quirks (bugs?) discovered, so far.

1.) The Date of the Date/Time Clock on the right-side of webUI pages are different (time correct, local TZ) —
Home versus Settings, time and language (sub-menu).

At 22:00 local time (April 20), one page displays date as April 20 - while the other page displays date as April 21. It appears the “date” in B3 webUI is using different underlying date references (gentoo/linux).
As mentioned earlier, the Clocks are identical, local time-zone (TZ). Only dates displayed differ.
Possibly one is taken from a UTC base, while other is taken from local (selected) time zone.

2.) Installing Bubbagen/Gentoo on new 3 TB hard drives (with no partitions) has an issue with this script /root/

3.) Accessing the Excito B3 webUI via Win10 browser: http://B3 was problematic (inconsistent).
Since the B3 acquires its IP address via my home router DHCP — this may be a local network issue.
I am still investigating, I will likely will need check DHCP service on the Excito B3 (turn off).

4.) Earlier forum posters have noted “unstable” issues with B3 miniservers.
Based on my previous work with original Bubba and Bubba|2 ...
installation of these images on new/used B3 miniservers — does require patience and linux familiarity.
Yet to Do:

1.) Configuration of the Wireless LAN (wlan0) is currently “locked” via Bubbagen webUI.
I need to decide on my desired network access with good security protections for this wireless port.

Last edited by beatgr on 04 Sep 2018, 15:03, edited 13 times in total.

Posts: 1388
Joined: 10 Aug 2011, 03:18

Re: Setting up a B3 miniserver

Post by Gordon » 21 Apr 2018, 15:41


Always welcome feedback. Should probably look into that blank disk issue, but that may be simpler said than done and hard to test without buying at least one new disk myself.

The date issue you are seeing is probably from one time being displayed in localtime and the other in UTC, possibly even the default setting of CET. I'm not completely sure which screens you are referring to though. Likely restarting the bubba-adminphp service will resolve the issue and if so I should add that to the timezone switching procedure. It may also require a full restart to align them all.

Name resolving is always tricky in an existing network. It should normally work if the DHCP server also declares itself as the DNS server, but then the domain can still be an issue.

Wifi support as offered by the GUI is to make the B3 an access point. This will bind the LAN interface (eth1) and wlan0 into bridge br0. The prerequisite for this is that you have a static address assigned to LAN. Of course you can also create an access point on wlan0 without bridging it to eth1, but then you'll have to edit the config files yourself. I actually run three SSID's myself on the B3, with two of them bridged to an ethernet vlan. Not sure if you can do that with NetworkManager though - I run the openrc version on my `production` system.

Posts: 1
Joined: 01 Jun 2018, 06:47

Re: Setting up a B3 miniserver

Post by DwightG » 09 Jun 2018, 11:36

Hi Graig, would you say that it's doable to work around those quirks or bugs? I'm considering setting up a B3 miniserver too, but not if I'll have more trouble than I can deal with.

Posts: 38
Joined: 01 Feb 2009, 15:25

Re: Setting up a B3 miniserver

Post by beatgr » 12 Jul 2018, 18:51

Dwight -
I used Gordon’s instructions for his Gentoo OS kernel.
My notes are for individuals to avoid potential issues, with a “clean install” on the B3.
Specifically, UBOOT upgrade (required for 3 TB hard drive) and the manual partitioning of a new (blank) Western Digital 3 TB (Red) hard drive. ... _3TB_disks

IF you did not understand those Gentoo installation steps (Why do that?, Options?),
THEN go back and re-read till you understand.

Last edited by beatgr on 14 Jul 2018, 19:59, edited 5 times in total.

Posts: 38
Joined: 01 Feb 2009, 15:25

Re: Setting up a B3 miniserver

Post by beatgr » 14 Jul 2018, 19:49

Gordon -

Logged into my Excito B3 (ssh) as “root” ,
Ran “genup” , and the eix-sync: reported it could not find

| Welcome to Gentoo Linux for the B3 miniserver! |
| Live-USB development: sakaki <> |
| Bubbagen admin UI: gordonb3 <> |
| There is ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law |
| (Edit, or delete, /etc/motd to modify this message) |

B3 ~ # genup
* Checking Portage configuration, please wait...
* Gentoo System Updater v1.0.15
* Updating Portage tree and syncing the eix cache
* (this may take some time)...
eix-sync: cannot find

* genup: Error: Caught signal - exiting
B3 ~ #

Posts: 1388
Joined: 10 Aug 2011, 03:18

Re: Setting up a B3 miniserver

Post by Gordon » 15 Jul 2018, 05:49

Hi Greg,

I use a crossdev machine to run the major part of the compile jobs and once in a while there is a package that gets confused by the crossdev root not being /

I did find that app-portage/eix is such a package and it hard codes the crossdev root inside its scripts, causing it to be unable to find include files. It's not a very big package and it should not take long to reinstall it. Sorry for the inconvenience.


Post Reply