New firmware update 0.31.4

Announcements of all software releases for Excito products
tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

New firmware update 0.31.4

Post by tor » 17 Apr 2007, 14:33

Release notes for Bubba 0.31.4
==============================
Excito is proud to announce the availability of the 0.31.4 firmware update. This release includes the major addition of UPNP media server capabilities, provided by the Mediatomb upnp mediaserver, making audio and video streaming a breaze.

How to upgrade
--------------
Make sure you don't have any activities running such as uploads, downloads, print jobs etc. Then log in as admin in web-ui. Chose "settings" menu entry. Select the tab named "Maintenance", the tabs are only present in newer versions of the firmware. On this tab, or the settings page if you have the old version of the web-admin ui, press the "Update" button located in the "Update software" field. After a while it should say "done" and the upgrade should be complete.

Warning, if you have modified your apt sources the web-admin ui should not be used for upgrades.

Major changes and new features
-------------------------------------
* Added UPNP media server
- Stream audio, video and watch pictures on UPNP capable renderers like DLINK 320 or 520, Nokias 770 and 800 tablet PCs to mention a few.
* Updates to the web based filemanager
- Added new download action. Mark any number of files and directories and download all at once in a zip-archive.
- New functionality for moving files and folders.
- New functionality for changing permissions on files and folders.

Updates and minor changes
--------------------------------
* A lot of minor cleanups in the web-admin ui.
* Some bugfixes in various parts including the Download manager.
* Updated libtorrent used by the Download manager
* Updated Avahi daemon to latest version.
* Added "total size" for torrents in the Download manager

jamerson
Posts: 80
Joined: 01 Feb 2007, 15:15
Contact:

Post by jamerson » 17 Apr 2007, 17:26

Updated!

Now Mediatomb (user: nobody) works a lot when I check top.
Is that a normal thing? The harddrive keeps working...

/pelle

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 17 Apr 2007, 21:11

Nice work with the file manager. Thanks a lot !

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Doesn't show up!

Post by Johnny » 18 Apr 2007, 01:15

My Bubba can't find any updates and it's currently running version 0.31.1.1.
When pressing the update button it gives me this answer:

Updating available sources... done
Checking for updates... done
0 package(s) to update.

No packages to update at this moment

/Johnny

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 18 Apr 2007, 03:25

Just updated, looks good !

However as I was using Bubbalibre's 'Tiny Little Hack' the new install did not seem to overwrite all the files in the /usr/share/web-admin and the interface looked strange (even after clearing my browsers cache). I then reloaded the 'Tiny Little Hack' and everything is now back to how it was.

I also had two Mediatomb processes running at a high level for 10 minutes or so, but they seem to have stopped whatever they were doing now. I guess they were on an initial discovery after being loaded up for the first time.

limpo
Posts: 59
Joined: 24 Mar 2007, 06:50

Post by limpo » 18 Apr 2007, 03:43

Hi,

Check out the webinterface for mediatomb:

http://bubba:49152



/limpo

johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Post by johannes » 18 Apr 2007, 03:49

Yes, the mediatomb server probably begins with indexing, that's why it's working for a while after installation.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

bubbalibre
Posts: 117
Joined: 01 Feb 2007, 09:33
Location: Paris, France

Post by bubbalibre » 18 Apr 2007, 04:27

Clive wrote:However as I was using Bubbalibre's 'Tiny Little Hack' the new install did not seem to overwrite all the files
Hi Clive,

Yes the file bubba.css is not overwritten. However the new file is in the folder, it's called 'bubba.css.dpkg-dist' (or 'bubba.css.dpkg-new', I don't remember).

Beeing root, you can delete the old file :

Code: Select all

rm /usr/share/web-admin/bubba.css
And then rename the new one :

Code: Select all

mv /usr/share/web-admin/bubba.css.dpkg-dist /usr/share/web-admin/bubba.css
That's it !

You can also check my tiny little hack 0.31.4 :wink:

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 18 Apr 2007, 13:00

What can I do to get my Bubba to find the new update? It still can't find any updates!

I have installed bubbalibre's "Tiny little hack"
http://excito.org/forum/viewtopic.php?t=113

and

the TorrentFlux php-based interface
http://excito.org/forum/viewtopic.php?t=89

Can this interfere with the update function?

/Johnny

Aitch
Posts: 11
Joined: 15 Feb 2007, 06:54
Location: Stavanger, Norway

Post by Aitch » 18 Apr 2007, 15:18

Johnny

You are better posting questions like this under requests for support.

I suspect that you have a firewall somewhere blocking access. I had to open ports 80 & 25 on my wireless router before I could get the update and mail checking functions to work.

/H

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 18 Apr 2007, 15:29

Johnny wrote:What can I do to get my Bubba to find the new update? It still can't find any updates!

I have installed bubbalibre's "Tiny little hack"
http://excito.org/forum/viewtopic.php?t=113

and

the TorrentFlux php-based interface
http://excito.org/forum/viewtopic.php?t=89

Can this interfere with the update function?

/Johnny
Hi Johnny,

Check that your update sources are OK -

My /etc/apt/sources.list is as follows -

#deb http://ftp.se.debian.org/debian/ sarge main
#deb http://security.debian.org/ sarge/updates main
#deb http://ftp.se.debian.org/debian/ sarge non-free

deb http://update.excito.net/ bubba main

Make sure the final entry is without a # (ie. uncommented)

Aitch
Posts: 11
Joined: 15 Feb 2007, 06:54
Location: Stavanger, Norway

Post by Aitch » 18 Apr 2007, 15:49

You guys are stars :D

I just loaded the update & am listening to my music streaming to the Media Player on my Nokia 770. Switch on my Soundbridge & there it is too. Great to see how hard you work at adding functionality and providing good support via the forum. Just keeps getting better & better.

/H

Clive
Posts: 144
Joined: 07 Mar 2007, 07:15

Post by Clive » 18 Apr 2007, 15:53

Me too ! :D

Back from work, switch on my Pinnacle Soundbridge and Mediatomb is streaming my music straight at it with no intervention - Top Job !

I prefer Mediatomb to Firefly as it allows me to browse the directory structure on Bubba from the Soundbridge rather than just showing the flat album list which Firefly did...

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 02:33

Aitch wrote:Johnny

You are better posting questions like this under requests for support.

I suspect that you have a firewall somewhere blocking access. I had to open ports 80 & 25 on my wireless router before I could get the update and mail checking functions to work.

/H
I guess you're right about posting this in the support dept.

I don't think it's my firewalls fault as both port 80 and 25 is open and directed to Bubba.

I have never had any problem updating Bubba before this firmware update, and hasn't made any changes to my local network either.

/Johnny

Johnny
Posts: 50
Joined: 20 Feb 2007, 14:42
Location: Sweden

Post by Johnny » 19 Apr 2007, 02:35

Clive wrote: Hi Johnny,

Check that your update sources are OK -

My /etc/apt/sources.list is as follows -

#deb http://ftp.se.debian.org/debian/ sarge main
#deb http://security.debian.org/ sarge/updates main
#deb http://ftp.se.debian.org/debian/ sarge non-free

deb http://update.excito.net/ bubba main

Make sure the final entry is without a # (ie. uncommented)
Thanks for the advice. I'll see if I'm able to find that somehow!

/Johnny

Post Reply