Checking disk temperature

A collection of tips on howto tweak your Bubba.
Post Reply
johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Checking disk temperature

Post by johannes » 23 May 2007, 06:18

The hard drive in your Bubba is the most sensitive part, it is recommended to keep the temperature as low as possible. According to the disk drive's data sheets, the operating temperature should not exceed 64°C (147°F) during operation, measured at the disk itself. However, keeping the temperature even lower will ensure a long life. Make sure that the ventilator openings on Bubba aren't covered, and don't place Bubba directly on top of or under other hot equipment.

All disk drives has built in temperature sensors. One way to check the temperature is to use the application hddtemp.

Installation

Using ssh, log on to Bubba (as your regular user). Type

Code: Select all

su
to become root. The root password is

Code: Select all

excito
To reach the 'hddtemp' Debian package, we have to enable that repository. Type

Code: Select all

nano /etc/apt/sources.list
Uncomment the row saying

Code: Select all

#deb http://ftp.se.debian.org/debian/ sarge main
..by removing the # sign. Save and exit. To update the package lists, type:

Code: Select all

apt-get update
Now, to install, type

Code: Select all

apt-get install hddtemp
You will get a screen asking for some settings. Following the default choices works good.

Now, restore the sources.list file:

Code: Select all

nano /etc/apt/sources.list
Put back the comment on the line saying:

Code: Select all

deb http://ftp.se.debian.org/debian/ sarge main
Save and exit.

Now you're done! To check the temperature, type:

Code: Select all

hddtemp /dev/hda
It should answer something like:

Code: Select all

/dev/hda: ST3160021A: 55 C
To allow for easier access to the temperature, you can always install phpsysinfo or other similar tools. This isn't in the scope of this guide however.
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

wmnelis
Posts: 8
Joined: 21 Jun 2007, 10:30

Error Message

Post by wmnelis » 21 Jun 2007, 10:35

Thanks for the info. I am interested in setting up my machine to tell me the drive temp automatically every time I log into it via ssh. I have successfully installed hddtemp via your instructions. However, when I run it I get the following error:

bubba:/dev# hddtemp /dev/hda
WARNING: Drive /dev/hda doesn't appear in the database of supported drives
WARNING: But using a common value, it reports something.
WARNING: Note that the temperature shown could be wrong.
WARNING: See --help, --debug and --drivebase options.
WARNING: And don't forget you can add your drive to hddtemp.db
/dev/hda: ST3320620A: 45 C or F

Any advice?

Also, I cannot seem to run this unless I am root. Is there a good way to set it up so I can run it as any user?

Thanks.

johannes
Posts: 1467
Joined: 31 Dec 2006, 07:12
Location: Sweden
Contact:

Post by johannes » 21 Jun 2007, 11:21

You can ignore the warning, it only states that your specific drive isn't in the hddtemp database. However, it tries to interpret the values read, and if you can read a reasonably correct value (as in your case), it works OK.

Regarding the root vs user rights I'm not the right person. Perhaps someone with more Linux knowledge can help out here?
/Johannes (Excito co-founder a long time ago, but now I'm just Johannes)

Per
Posts: 12
Joined: 03 Apr 2007, 14:03

Post by Per » 21 Jun 2007, 15:06

You drive is not present in the hddtemp database. You find this file in /etc/hddtemp.db. You should add a line repesenting you drive, look at the present entries and in hddtemp man page.

A typical entry is like this:

Code: Select all

"ST3500630A"                            194  C  "Seagate ST3500630A 500GB"
You should have a entry for ST3320620A. C is for celcius and the number is the SMART entry number.

Run

Code: Select all

hddtemp -D /dev/hda
to see all SMART entries for you drive. Then you have to guess what entry is the temperature. The value that changes like a temperature reading is the one. On segate it probable is 194.


To be able to ru hddtemp as other user then root, you run

Code: Select all

dpkg-reconfigure hddtemp
as root and follow the questions.

/Per

wmnelis
Posts: 8
Joined: 21 Jun 2007, 10:30

Worked!

Post by wmnelis » 23 Jun 2007, 12:16

Great! That worked perfectly. Thanks for the help Per.

Rawhead
Posts: 42
Joined: 18 Mar 2007, 07:10
Location: Infected mountain in Sweden
Contact:

Post by Rawhead » 14 Feb 2008, 14:35

I dont have the file /etc/hddtemp.db :( what 2 do

Cheeseboy
Posts: 789
Joined: 08 Apr 2007, 12:16

Post by Cheeseboy » 15 Feb 2008, 21:00

Hello Rawhead,

Did you follow the instructions on how to install it?
Did you get any error messages whilst installing it?

Do you get any hits if you type in this as root:

Code: Select all

find / -name hddtemp.db
/Cheese

Rawhead
Posts: 42
Joined: 18 Mar 2007, 07:10
Location: Infected mountain in Sweden
Contact:

Post by Rawhead » 16 Feb 2008, 03:08

Thanks I did solve this issue. dont know how but the file was there in the end. Me blind sometimes

Brulsturm
Posts: 3
Joined: 03 Jan 2009, 17:47

URL Doesn't exist anymore?

Post by Brulsturm » 03 Jan 2009, 18:09

Apparently, at least 1 URL in the "sources.list" doesn't seem to exist anymore.
Because after the commando, "apt-get update", I get this errormessage:

"Failed to fetch http://ftp.se.debian.org/debian/dists/s ... rm/Release Temporary failure resolving 'ftp.se.debian.org'
Failed to fetch http://update.excito.net/dists/bubba/ma ... ackages.gz Temporary failure resolving 'update.excito.net'"

I tried this guide to install HDDtemp on my Bubba(1) several times and this message always shows up.

Internet connection is OK. Softwareversion on the Bubba is: 0.52.2-1

Any suggestions?

Thanks in advance.

Brulsturm
Posts: 3
Joined: 03 Jan 2009, 17:47

solved: incorrect URL's in sources.list

Post by Brulsturm » 05 Jan 2009, 16:01

Thanks to some other part of the forum, I managed to get the APT working again; replaced the 3 upper lines with this one:

HTTP://archive.debian.org/debian sarge main non-free

greetings, Brulsturm

hastalapasta
Posts: 14
Joined: 23 Oct 2008, 04:47

Re: solved: incorrect URL's in sources.list

Post by hastalapasta » 31 Jan 2009, 19:27

Brulsturm wrote:Thanks to some other part of the forum, I managed to get the APT working again; replaced the 3 upper lines with this one:

HTTP://archive.debian.org/debian sarge main non-free

greetings, Brulsturm
And which thread was that?

Post Reply