RESOLVED: webmail and web-admin MIA

Got problems with Bubba? Then this forum is for you.
Locked
JanLarsen
Posts: 18
Joined: 18 Apr 2008, 17:11

RESOLVED: webmail and web-admin MIA

Post by JanLarsen » 01 May 2008, 12:29

I messed up my apache.
I was trying to configure my postfix to send via my ISPs SMTP and following a howto I did

Code: Select all

apt-get install postfix-tls
which gave me an error indicating that I should do

Code: Select all

dpkg --configure -a
I did and this produced another error indicating some problems with the apache-mod-php4 dependency. It also suggested I do

Code: Select all

apt-get -f install
which I did. Among the things it did was a reload of apache. Completing the howto, my mail started working as expected, but then I discovered that my apache only returned 404. There are no entries in the access log but the error log started writing

Code: Select all

[Thu May 01 18:03:48 2008] [error] [client 83.138.130.159] File does not exist:
/htdocs
for my website, webmail and web-admin.

I have rebooted with no change.

I have no clue what went wrong and any suggestions are most welcome!

EDIT:
I discovered that there are no files in sites-enabled. Thats not good.
EDIT2:
Enabled site "bubba" and got my website up. Webmail and web-admin still not working. Error is now:

Code: Select all

[Thu May 01 18:51:31 2008] [error] [client 85.82.199.178] File does not exist: /
var/www/html/web-admin, referer: http://javacon.dk/bubba/
and true enough I have no web-admin there. So what config file was overwritten? Was bubba in enabled different from bubba in available? Is yours?
Edit3:
seems like the bubba package was removed. After reinstall webmail and web-admin exist but php seems to be non-functional; my browser asks what to do with the php files it has just downloaded.
I guess I can get in line with the others who have messed their bubba application up when trying to upgrade.
Last edited by JanLarsen on 02 May 2008, 12:02, edited 1 time in total.

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 01 May 2008, 14:35

Hi
strange that you got this error.
you can check if the bubba package is still available.

Code: Select all

dpkg --list|grep bubba
This should give you your version of the bubba package, starting with ii which indicated that it is installed.

Most likely through the reconfigure of apache, it removed a bubba apache conf file, just like it removed bubba from the site-enabled.
The error you get indicates it misses the file web-admin file in the directory /etc/apache2/conf.d
Create it:

Code: Select all

vi /etc/apache2/conf.d/web-admin
This should be in the file
Alias /web-admin "/usr/share/web-admin/"
<Directory "/usr/share/web-admin/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
AddType application/x-httpd-cgi .cgi
Options ExecCGI
</Directory>
Restart apache and you should be fine.

cheers
Eek

JanLarsen
Posts: 18
Joined: 18 Apr 2008, 17:11

Post by JanLarsen » 01 May 2008, 14:53

Thank you Eek. I think you are right, but by the time you replied I had reinstalled bubba (and with it IlohaMail and libapache-mod-php4) and the file was back in place.

Code: Select all

bubba:~# dpkg --list|grep bubba
ii  bubba          0.52.2-1       This is the filesystem for Bubba
Now however, php doesn't seem to be working; apache serves the php-files to my browser instead of interpreting them. I don't have a php.conf in conf.d. Should I?

My problems might arise from installing subversion in accordance with the howto. I modified my apt sources and left them modified.

EDITs:
php module was not enabled

Code: Select all

bubba:/# a2enmod php4
Module php4 installed; run /etc/init.d/apache2 force-reload to enable.
bubba:/#  /etc/init.d/apache2 force-reload
Forcing reload of web server: Apache2.
which fixed web-admin!
Now what do I enable to get IlohaMail working: browser asks what to do with:

Code: Select all

application/x-httpd-php
AAHH a simple cache problem.

Well I guess I am good. This was... interesting :D

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 02 May 2008, 12:59

Great it worked out.
You should have a php4.conf in the directory mods-available,
which should have the AddType application/x-httpd-php .php
As you are not the first and not the last :D
to have suddenly things not work out or package de-installed... etc
What i now do to try and prevent these kind of things is use the -s parameter with apt-get.
This simulates the install, but does not actually install.
This saved me a couple of times, because i saw that for a simple package install it wanted to deinstall my package bubba and dovecot, etc !
hope it helps

cheers
Eek

davidb
Posts: 15
Joined: 30 Jan 2008, 11:51

Post by davidb » 12 May 2008, 10:57

Where do I find this mods-available?

Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

Post by Eek » 12 May 2008, 13:21

/etc/apache2/mods-available

davidb
Posts: 15
Joined: 30 Jan 2008, 11:51

Post by davidb » 12 May 2008, 16:37

Thanks!

JanLarsen
Posts: 18
Joined: 18 Apr 2008, 17:11

Post by JanLarsen » 14 May 2008, 14:00

Here is a nice description of managing apache in debian.

Locked