Debian jessie image 1.0 released for Bubba|2 / B3

Discuss development on Bubba
Binkem
Posts: 388
Joined: 10 Jul 2008, 02:26

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by Binkem » 13 Nov 2016, 15:31

### Solved it: just had to restart after updating te kernel... ###

I get the following reply:
/sbin/depmod -a
depmod: ERROR: could not open directory /lib/modules/3.18.24-1: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
I updated several times already.

Stryker
Posts: 55
Joined: 17 Oct 2013, 11:03

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by Stryker » 24 Apr 2017, 21:31

e: I'll keep the stuff below for posterity, but the problem was solved by FIRST flashing the new U-Boot ("Rodeus" Version from Mouette's Github), then running the jessie-1.0 installer afterwards instead of the other way around.

Original problem:
So, I have 3 B3s now and something weird is going on.
I compiled and flashed a new U-Boot based on your "rodeus" Version from Github.
I have the same U-Boot on all my devices now, but they show different behaviours even though they should be identical.
They only differ in Hardware Rev. and whether they came installed with a wifi card or not.

An overview:

Code: Select all

Disk A: 500GB Kernel 2.6.39.4-11 #1 Tue Apr 3 21:45:12
Disk B: 250GB Jessie-1.0 Kernel Linux b3 3.18.48-3 #1 Fri Mar 10 15:22:01 UTC 2017
Disk C: 3TB   Jessie-1.0 Kernel 3.18.48, same image

B3 prime
PC1 Board - Wifi - U-Boot 2013.01.01-b3-rodeus-gab59ad7 (Apr 21 2017 - 16:32:01)
A - works
B - does not work
C - does not work

B3 alpha
PB1 Board - Wifi - rev1 U-Boot 2013.01.01-00006-ge588a77-dirty (Aug 25 2014 - 23:39:35) (L2-Cache-Fix by Mouette)
		   rev2 U-Boot 2013.01.01-b3-rodeus-gab59ad7 (Apr 25 2017 - 02:07:51) compiled on this device
A - works		rev2: works
B - does not work	rev2: does not work
C - does not work	rev2: does not work

B3 beta
PB1 Board - LAN  - U-Boot 2013.01.01-b3-rodeus-gab59ad7 (Apr 21 2017 - 16:32:01)
A - works (this disk with this board were the source for the rodeus U-Boot I flashed on this and PC1 board)
B - works
C - works
What weirds me out, is that even though the B3 alpha and beta are identical, only beta works with the more recent kernels.

Stryker
Posts: 55
Joined: 17 Oct 2013, 11:03

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by Stryker » 26 Apr 2017, 09:11

Okay, more testing revealed some insights into a possible problem with the B3-Debian jessie-1.0 image.
Setup:
One Disk with B3-Debain-jessie-1.0, but two B3 boards (called alpha and beta) with the same U-Boot

Problem:
If you swap the Board, but keep the same OS installed on disk, the ethernet ports do not come online and you cannot get access to the device.

Diagnosis:
I first thought it might be a problem with the U-Boot, but that is not the case. The OS actually boots and runs fine, but it is only accessible by configuring the wifi card and then transfer the card between the boards.

/etc/network/interfaces configures eth0 and eth1 during installation of the image with the alpha board.
When you boot with the beta one, it detects two new ports eth2 and eth3 for which there are no entries in the interfaces-file.
So I want to ask whether there is an instruction that ties the OS-Image to its board during install, perhaps by hardcoding the MAC-adresses.

e: systemd-udevd seems to be the culprit here:
dmesg output on beta:

Code: Select all

[    6.824902] mv643xx_eth_port mv643xx_eth_port.1 eth3: renamed from eth1
[    6.832367] mv643xx_eth_port mv643xx_eth_port.0 eth2: renamed from eth0
[    6.843211] systemd-udevd[119]: renamed network interface eth1 to eth3
[    6.851375] systemd-udevd[120]: renamed network interface eth0 to eth2

86ivar
Posts: 148
Joined: 02 Oct 2010, 11:08

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by 86ivar » 11 Jan 2018, 11:59

B2 will not boot when I have a mount in fstab with UUID and the disk is not attached. with other machines I dont have this problem. How do I set up a recovery usb with this image to fix b2?

Edit: Have I got these parameters right in the install.ini file?

Code: Select all

## defaults
# [general]
# image = None (rescue system only)
# wipe = false
# size = 10
# swap = 512
# reboot = true

[general]
image = none
wipe = false

MouettE
Site admin
Posts: 248
Joined: 06 Oct 2011, 19:45

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by MouettE » 11 Jan 2018, 12:17

Hello,

just remove the image line (you could also remove the general section altogeter but I'll understand if you'll leave wipe at false ;-) ). If image si not provided or if the file does not not exists, the installer will exit leaving the rescue system running.

OldB3User
Posts: 3
Joined: 28 Oct 2018, 04:06

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by OldB3User » 28 Oct 2018, 04:32

Hi.

I inadvertently locked myself out of my B3. I am trying to use the Jessie rescue system to correct it (image = none, wipe = false). I can ping the B3 when it’s running the recuse system but I can’t log in via ssh with the username/password combination excito/excito. Is the password for the rescue system different to the install image?

MouettE
Site admin
Posts: 248
Joined: 06 Oct 2011, 19:45

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by MouettE » 28 Oct 2018, 07:16

There is no excito user on the install/rescue system. Login with root/excito.

OldB3User
Posts: 3
Joined: 28 Oct 2018, 04:06

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by OldB3User » 28 Oct 2018, 07:32

MouettE wrote:
28 Oct 2018, 07:16
There is no excito user on the install/rescue system. Login with root/excito.
Thanks Mouett. I’m pretty sure I tried that too but will try again later.

OldB3User
Posts: 3
Joined: 28 Oct 2018, 04:06

Re: Debian jessie image 1.0 released for Bubba|2 / B3

Post by OldB3User » 28 Oct 2018, 11:29

root/excito doesn't work and neither does any other combination of root/excito/admin. I have re-flashed my USB stick with a fresh download to be sure. :cry:

[EDIT]Never mind, got it working. Thanks.

Post Reply