gentoo-b3-overlay and sakaki-tools permanent errors in portage tree

Discuss development on Bubba
Post Reply
Gordon
Posts: 1433
Joined: 10 Aug 2011, 03:18

gentoo-b3-overlay and sakaki-tools permanent errors in portage tree

Post by Gordon »

gentoo-b3-overlay and sakaki-tools permanent errors in portage tree

As of last week (2022/31) the Gentoo devs have retired ebuild EAPI 5. This causes permanent errors in the portage tree on several of the abandoned ebuilds that were created by Sakaki and were written using this EAPI. Note that this is not a fatal error and it will not prevent you to update your B3 software but of course this situation should not persist.

I'm currently not sure how to fix this for existing installations as part of the regular update routine, especially for Gentoo users that do not have the Bubbagen package installed, but I will be releasing a new Bubbagen image that is not affected by this issue in a few days. Should anyone be interested in manually fixing it themselves please post below.
Post Reply