Page 1 of 1


Posted: 31 Mar 2015, 14:23
by fabio
Good afternoon,

I love my B3 but it is now showing its age. I saw topics to install wheezy on B3: do you think would it be possible to install OpenMediaVault once Wheezy is installed?

Or has anyone installed OpenMediaVault on B3?

Thank you


Re: OpenMediaVault

Posted: 05 Apr 2015, 14:28
by fabio

I managed to install it and it works quite well. CPU load is not so high and memory allocation is ok, as well as performances.

It is so easy to quickly install transmission, minidlna, dnsmasq and all the required services.

B3, after 4 years, still does a wonderful job, and with OMV it is living a second life :)

Re: OpenMediaVault

Posted: 05 Apr 2015, 22:20
by past_51
Hi fabio,

I'm interested by your experience.
Any problem with OMV ? Are all plugins working ?

Which topics did you followed to install Wheezy ?

I'm currently hesitating between ArchLinux (sakaki's version) and an updated Wheezy version.

Thanks for your feedback :)

Re: OpenMediaVault

Posted: 16 Apr 2015, 10:52
by fabio

the plugin I needed are working correctly (MiniDLNA, DNS, Transmission + few others).

There are some smaller glitches when running with 1 drive only but overall it is a pleasure to use.

Please note that the "apt-get" install for OMV (the only viable with B3) is not officially supported so there are some specific things that you really need to take care before installing.

I have taken some notes but need to find some time write a proper tutorial...find here my notes

Instal squeeze on B3 via USB (need to find the link to the how to, but is straighforward)

login as root/excito

Connect your lapton to b3 ( with a cable to LAN
apt-get update
apt-get upgrade

VERY IMPORTANT: add/amend local B3 name and IP in etc/host, this will allow the installation to finalize (otherwise blocked by collectd)


echo "deb kralizec main" > /etc/apt/sources.list.d/openmediavault.list
apt-get update
# Note: You will get a warning that the PGP Key can't be found. Thats fine.

apt-get install openmediavault-keyring postfix

(when promted in postifx select no configuration
# Note: You will get a warning that the package 'openmediavault-keyring' can't be authenticated. You're fine to ignore that warning and install it anyways.

apt-get update
apt-get install openmediavault

choose UTF/guess character set
proftp to run as inetd

run omv-initsystem

- run omv-firstaid to change admin password (although doc says it is "openmediavault", the apt-get method doesn't set it but it uses the local admin pwd instead)
- enable ssh, disabled by default (very important)
- If you get an error about wrong json file, just to an rm of that file

- go to and change interface address of LAN


Please do not change any partition/LVM or B3 will hang at boot.

Re: OpenMediaVault

Posted: 29 Apr 2022, 04:11
by GodfatherB
I'll pick up this thread if anyone can help...

Did anyone try to install OMV6 to B3 (on fresh bullseye image from Mouette)? I installed bullseye with 16GB system partition, 512MB swap, for the rest I created ext4 partition. I tried to install OMV6 according to this guide: ... -bullseye/ . The installation seems to go well until a certain point (Deploying service configuration...) then the ssh connection gets severed and I cannot log back into B3 at all. I'm lost at this point. I reinstalled bullseye several times now (the only way I figured to get back into B3) tried some different tweaks, but no luck so far (my ssh connection always drops on the same point).

Last few lines of installation procedure...

Code: Select all

Generating public/private rsa key pair.
Created directory '/root/.ssh'.
Your identification has been saved in /root/.ssh/id_rsa
Your public key has been saved in /root/.ssh/
The key fingerprint is:
SHA256:cmNKVLmivc1nIfnpUV/2AgLvbdJQYJpzKcUCb64nHzs root@b3
The key's randomart image is:
+---[RSA 3072]----+
|      ...o+      |
|       oo=.o     |
|      . Ooo .    |
|     ..o.* .     |
|     oo.S.+ o   o|
|    ...*oo.* o o.|
|      ++oo+o+ o .|
|      .+Eo=+   . |
|        o=.      |
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-beep-up.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-beep-down.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-beep-down.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-beep-down.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-cleanup-monit.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-cleanup-php.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-engined.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/openmediavault-issue.service.
Creating configuration database ...
Setting up Salt environment ...
Setting up system ...
[WARNING ] /usr/lib/python3/dist-packages/salt/utils/ RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  f_handle = open(*args, **kwargs)  # pylint: disable=resource-leakage

[WARNING ] /usr/lib/python3/dist-packages/salt/utils/ RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  f_handle = open(*args, **kwargs)  # pylint: disable=resource-leakage

Deploying service configurations ...
I would appreciate any help on the matter. I am rather newbie regarding linux. Thank you.

Re: OpenMediaVault

Posted: 26 May 2022, 15:46
by yghern
I just want to let you know that I successfully installed OMV5 on b3 buster 1.1 image. Works fine so far (at least the installation does not hang up in the middle...). Web UI works fine, little sluggish but nothing to write home about.
My b3 got into boot loop during OMV6 installation over the bullseye image. I briefly browsed the OMV forum, but couldn't find any resolution.

Re: OpenMediaVault

Posted: 27 May 2022, 17:22
by yghern
Short update.
I am able to install omv6 on b3 bullseye. Steps below.
1) Install bullseye image on b3
2) apt update && apt upgrade
3) fix /etc/hosts by adding line (without it one of the omv dependency package fails) b3
4) Create /etc/default/openmediavault with modified watchdog variables (without in installation of omv package fails miserably) ... post298806 ... 1016001880
5) Create omv source files
echo "deb shaitan main" > /etc/apt/sources.list.d/openmediavault.list
6) Install omv gpg key
apt-get install --yes gnupg
wget -O "/etc/apt/trusted.gpg.d/openmediavault-archive-keyring.asc"
apt-key add "/etc/apt/trusted.gpg.d/openmediavault-archive-keyring.asc"
7) Install omv; remember not to use "noninteractive" on "autoapply" options, see next step
apt update && apt install openmediavault-keyring openmediavault
8) During openmediavault package installation you'll be asked what to do with conflicting changes (as the package tries to overwrite the file we created at step 4). The best solution is to open the shell (Z), edit the file, merge the content with new defaults, save, exit, and keep the local version (N option). I'll include the default options that I copied from Raspberry Pi forum.
That's it! Welcome to OMV6 on your B3. Web UI is responsive, and config update takes less than a minute.

Disclaimer - I currently am not able to add any shares (mainly that's the reason I'm shuffling with image/omh versions...) but I'm working on it.