Page 1 of 1

Buster image ?

Posted: 03 May 2022, 10:22
by drdr6
I noticed that people have kindly worked on a Buster image for B3.
I picked up one of my old B3s with the intent of deploying it.
However the B3 is running Stretch and doesn't have mtd_utils installed, so don't think I can easily deploy the u-boot update.
The HDD is the original WD 1Tb model; can anyone tell me if the u-boot update is *required* to support a kernel > 2.6.39 ? If it is, can a stepwise upgrade be done through an intermediate version where I can get hold of mtd_utils?

thanks in anticipation

Re: Buster image ?

Posted: 03 May 2022, 19:32
by drdr6
I decided to give it a go. I have 3x B3 boxen, one of which I know has had the u-boot update, so I wasn't expecting to have a problem with that one.

Now they're all dead, and won't install an image. Install says it's done, blue light comes on, but LAN ethernet port both lights on even when no connection and WAN ethernet port no lights on, connection or not.

The reason seems to be that the HWclock is getting clobbered in the install process back to 2000, and then the install process fails because TAR sees the archive date as being in the future.

Ideas please? Short of wiring a serial terminal I can't see a way to reset the HW clock or get the install process to ignore the clock discrepancy at least until the image is properly installed and I have a chance to log in.

Re: Buster image ?

Posted: 04 May 2022, 13:05
by Gordon
The u-boot update is only required if you want to install a larger disk or one that uses newer firmware.

I'm not sure how you established that there is a hwclock issue, but it is not unlikely that it broke all together. It has on one of my B3s and I counter that by syncing the clock at boot time. One way to fix it is to start the install USB in rescue mode (, set a valid date/time and then manually untar the payload file to the disk.

Re: Buster image ?

Posted: 19 May 2022, 06:02
by drdr6
I reasoned about the hwclock issue primarily from the string of error messages from tar in the installer log about dates being in the future.

After rebuilding rootfs.cpio.xz with the install script modified to say "tar -xmf <path>" so that tar ignores the clock, the install completes with no error (according to the installer log). The box boots after a normal period of disk activity to a blue LED, but the ethernet ports are both unresponsive. The LAN port has both LEDs on and the WAN port has both LEDs off; both ports will flash the activity light when connected to a host doing DHCP.

this happens on all three boxes; I know I updated uboot on one of them so it doesn't appear to be that as a problem. Anyone recognize this "both LEDs solidly on with the LAN port" issue?

Re: Buster image ?

Posted: 22 May 2022, 11:59
by drdr6
A bit more experimentation:

The only install that seems to leave the box in a workable condition is a full install from the image. Trying to install anything else leaves the box with the blue light on but with a broken network (LAN both lights on, flickers when client tries to do DHCP, WAN both lights off, flickers when tries to do DHCP; in both cases clients sent plenty of packets to B3 but get no packets back)

Even trying to get in with the image set to recovery (DO_INSTALL=0) doesn't get the network running after trying a newer image.

Re: Buster image ?

Posted: 22 May 2022, 17:32
by Gordon
Did you try connect to the fallback address ( Just to state the obvious, your workstation must hold an address in the 192.168.10.x range as well to make that attempt successful.

Re: Buster image ?

Posted: 08 Jun 2022, 17:31
by drdr6
[back on this after being away for a while]
Yes, I have tried connecting to, no joy

When I set the image to recovery mode (DO_INSTALL=0) then the green light stays on.

The host it's connected to ( has an active DHCP server and it sees one DHCP request (from a MAC address corresponding to an Excito product) and provides an IP address (something like, but the B3 doesn't respond to ping, or have any ports listening (nmap). The LED status indicates that the Ethernet port is not up on the B3 either.

This is consistent behavior across all three B3 boxes I have.

Re: Buster image ?

Posted: 18 Jun 2022, 04:20
by fredrikj
@drdr6 There is a Debian 11 Bullseye installer too. Bullseye supersedes Debian 10 Buster. Do you have any particular reason not to try the latest version of Debian for B3? - Bullseye installer

viewtopic.php?t=6522 - Bullseye announcement by Mouette.

I cannot recall anything specifically wrong with networking for the Buster version. If networking doesn't work out of the box on three different B3 there may be something wrong with your network, either physical with cables and hubs, switches, or router, or the network configuration.

Though I'd strongly recommend installing Bullseye on one B3 first, rather than continued attempts to track down problems on a older version of Debian. And do check network cables and network configuration - but install bullseye first.